Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

(I asked this question on SuperUser 3 days ago and had no answer...)

I would like to access my freshly installed apache server (via ports) on my FreeBSD guestOS from Windows 7. So I set my virtual network on VMWare to bridged, I edited the hosts file on my Windows, I opened a browser on Windows and tried to reach 192.168.0.13 (guest's address)... But still, I can't get to my index.html web page. Google says that it cannot connect to 192.168.0.13. The only thing I can do to see my "It works!" page is

lynx localhost

on freeBSD.

I disabled my Windows firewall, I can ping my FreeBSD from my Windows, and my Windows from my FreeBSD.

What am I missing?

EDIT:

I have no proxy, and my httpd.conf file has been correctly edited. Here it is : http://pastebin.com/w9Q7Tq26

share|improve this question
    
What exactly do you mean by "can't get to my index.html". Does the browser time out? Do you have a proxy configured for the browser? FreeBSD's default configuration has no firewall, did you have one enabled that you disabled, what exactly do you mean by "disabled my firewalls" in relation to FreeBSD? How was Apache installed? Did you change it's configuration at all? –  Chris S Jul 13 at 2:55
    
Is my question clearer now? –  Amina Jul 13 at 3:19
1  
Try run command lynx 192.168.0.13 from freebsd. Did you see "It works" page? –  masegaloeh Jul 13 at 5:00
    
I get "unable to connect to remote host". –  Amina Jul 13 at 12:40
    
Sounds like something in httpd.conf is off. Can you scrub and dump it to something like pastebin.com ? –  Chris S Jul 13 at 14:29

1 Answer 1

up vote 0 down vote accepted

Is FreeBSD firewall allowing EXTERNAL connections on port 80? You have not specified that you've checked this in your question.

Also make sure you have bind your server not only to localhost:80, but to 192.168.0.13:80 or *:80 in general as well

share|improve this answer
    
Thank u! Now it works! I didn't know that I had to add *:80, I thought using localhost only would do the thing... Thanks again :) –  Amina Jul 13 at 15:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.