Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've recently inherited a website, where the staff almost all use webmail. Fair enough. One staff member told me that three other staff members had left, and that she needed to see those emails.

Rather than give a user logins, or forward several hundred megabytes of messages, I opted to just copy the folders underneath hers.

So, I have staff1 who's there, and a, b and c who have all left. I copied their so it looks something like this:

/mail/
  -> /staff1/
     -> .folder 1
     -> .folder 2
     -> .mail from a
        -> **folders from that user, such as drafts, junk, sent, inbox, etc**
     -> .. etc ..

That's all done. However the user told me that they couldn't see any folders. Thinking it was a permissions issue, I ensured that the folders I copied had the same owner id, and permission mask as the folders she could see.

Unfortunately, that didn't work - I had to edit a courierimapsubscribed file to let the webmail program about the folders. The user can now see the folders in her list, but she can't read the contents.

Horde can see the folder, but cannot display messages in it. SquirrelMail complains about not being able to open the folder, giving this error:

ERROR: Could not complete request. Query: SELECT "INBOX.mail from a" Reason Given: Unable to open this mailbox.

The website is hosted via HostGator, and appears to run sendmail on Linux. Her webmail weapon of choice is SquirrelMail.

How can I give this user the ability to read the several hundred emails contained in these folders?

share|improve this question

1 Answer 1

Do you have other ways to connect to the mail-storage?
Perhaps IMAP?

Then you could try to use imapsync or similar program or just use a MUA like Thunderbird or such and Copy the mails from one account to the other.
Of course you have to enter both accounts in one Thunderbird-profile.

Since you're using Courier as IMAP-Server (I only guess because of the courierimapsubscribed) all mails should be stored as single files with a very long filename.

Make sure that you use the option '-R' when doing a chown or chmod

Does your Webmail and Mailserver handle spaces in foldernames?
Try renaming your folder!

Doing a

chown staff:staff .mail_from_a -R
chmod 700 .mail_from_a -R

should help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.