Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm learning to use the KVM on CentOS 7 right now. For some reason Red Hat decided to disable the possibility of installing an OS on a virtual machine from a CD\DVD-Rom in RHEL 7. When creating a new VM through the VM Manager the "Use CDROM or DVD" option is greyed out and unavailable and the hint says "Physical CDROM passthrough not supported with this hypervisor". I found a couple of bug descriptions related to the issue, but all of them have to do with ramifications of CDROM passthrough disabling and neither describe the reason of why it was disabled in the first place. The bugs are from Red Hat's bugzilla:

Both of them refer to 760885 bug that apparently describes the reason. Unfortunately it isn't made public and access is denied even after registration.

Can anyone shed a light on why they have disabled such a seemingly useful feature? Is it a security or functionality issue?

Thank you, golem

share|improve this question
I don't know why this was done, but I can say I haven't actually needed to do it in many years. Using images is much more convenient. – Michael Hampton Jul 15 '14 at 2:10
Turn the cdrom into an image using dd if=/dev/cdrom of=/path/to/image.iso and attach the ISO. – dyasny Jul 15 '14 at 13:23

2 Answers 2

up vote 4 down vote accepted

Disclaimer: I work for Red Hat but have no idea about the decisions related to this particular bug. I made a request, though, and the bug is now public.

The short version is: passthrough seems to have a lot of bugs in different situations, none of them simple fixes, and it (again, really not speaking officially here) seems like it was judged to not really be good to expose to users. (For example,

However, there is work on fixing many of those, and it may be re-enabled at some nebulous point in the future. (But I do suggest using the suggestion above to make an file image from your CDROM and using that.)

share|improve this answer

Maybe not directly related but I could solve my issue using USB-Passthrough on my CD/DVD/BluRay-Player connected via the USB port.

The biggest issue there was that "virsh/virt-manager" by default defines USB1.0 ("-device piix3-usb-uhci,...") for Pass-Through instead of USB2.0 ("-device usb-ehci,..."). See as well: "".

Other issues were to shift from "virsh/virt-manager" over to "plain" "qemu-system-x86_64" and "spicec" and "Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.