Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an IPv6 address added to a bridge (sysctl has been configured to enable forwarding). However whenever I try to ping an IPv6 host it fails with the following error:

PING google.com(we-in-x65.1e100.net) 56 data bytes
From 2a00:dd0:0:28:216:3eff:fe1a:b34a icmp_seq=1 Destination unreachable: No route

This is my /etc/network/interfaces (Debian) config:

iface xenbr0 inet6 static
        address 2a00:0dd0:0000:0028:0000:0000:0000:0001
        netmask 64
        gateway 2a00:0dd0:0000:0028:0000:0000:0000:0000

This is the routing table:

root@nl:~# route -6 | grep dd0
2a00:dd0:0:28::/64             ::                         U    256 0     1 xenbr0
::/0                           2a00:dd0:0:28::            UG   1024 0     0 xenbr0
2a00:dd0:0:28::/128            ::                         Un   0   1     0 lo
2a00:dd0:0:28::1/128           ::                         Un   0   1     7 lo

I got this from my ISP as my "IPv6 block": 2a00:dd0:0:28::1/64. No other info was given.

Wondering if this is a router issue on their end or one on mine?

share|improve this question
    
You should request more info from your provider... Also, are you sure that this is your subnet? usually, you get a /48 assigned, and the /64 is just for the routing between you and the provider. –  MichelZ Jul 16 at 16:58
    
@MichelZ I requested information but i'm still waiting to hear back. Yeah in my IP pools 2a00:dd0:0:28::1/64 is the only thing listed, I requested a /64 so I imagine this is it. –  user677183 Jul 16 at 17:00

2 Answers 2

up vote 0 down vote accepted

2a00:dd0:0:28::1/64 is probably your default gateway since a block can't end with 1. Your host ip is set to the address of your default gateway and your default route points to your entire block 2a00:dd0:0:28::.

Use a subnet calculator to figure out the range of addresses in your block and change your host IP. Then see if you can ping 2a00:dd0:0:28::1. If so try using it as a default gateway and then try to ping another internet host. If these settings don't work contact your provider.

Also I haven't tried any google v6 addresses, but if you haven't successfully pinged them from another host try from a working host to make sure they answer.

share|improve this answer
    
Seems like you're right, that is the gateway. I'm now getting stuck at one of their routers in a traceroute so I assume it's no longer a problem in my server. –  user677183 Jul 16 at 17:07
    
They could be blocking traceroute or tunneling through a network that doesn't support it. Is any of your traffic getting to the internet (web, dns, etc.)? If not I'd open a ticket with them. –  keegan2149 Jul 17 at 16:20

You need to find out the gateway from your ISP. Either their router is 2a00:dd0:0:28::1, or they expect you to have an additional IP on some other block of space that they route to 2a00:dd0:0:28::0/64 via.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.