Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to configure roundcube webmail and I get the error

"Can't initialize character set utf8 (path: /usr/share/mysql/charsets/))"

I fixed this before on my website by adding ;charset=UTF-8 to the end of the "mysql:host=" line for my db connection. This means a utf8 charset exists but it is being picky about the format.

I have tried adding the following to /usr/share/mysql/charsets/Index.xml

<charset name="utf8">
  <family>Unicode</family>
  <description>UTF8 Unicode</description>
  <alias>utf8</alias>
  <collation name="utf8_general_ci" id="33">
   <flag>primary</flag>
   <flag>compiled</flag>
  </collation>
  <collation name="utf8_bin"        id="83">
    <flag>binary</flag>
    <flag>compiled</flag>
  </collation>
</charset>

I still get the same error message. How do i add a new charset or overcome this issue with mysql requiring the charset to be specific.

I have tried searching through the php files for roundcube hoping to find the db connection line so i can add the - to uft8 but i am unable to find it.

share|improve this question
    
Where exactly is that error coming from? That doesn't look like a standard Mysql error message. –  Zoredache Jul 17 at 21:15
    
is shows up in the mysql error log. I changed the uft-8 charsets name to utf8 and it fixed the problem. it just seems weird that there cant be 2 –  Dan Hastings Jul 17 at 21:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.