Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded and installed the Windows Server 2012 R2 evaluation version from Microsoft's Evaluation Center website. We decided to go ahead and activate it to the full version. We bought a Windows Server 2012 R2 Standard DVD and attempted to use the Key provided with the DVD following the method described here:

Yes, I did notice the mistake in the instructions and instead of finding out my version, I used "DISM /online /Get-TargetEditions" command to be able to get the correct parameter for the version of Windows Server I intend to upgrade to. The result was "ServerStandard".

So now, the new command is "DISM /online /Set-Edition:ServerStandard /ProductKey: /AcceptEula". I get the error the product key could not be validated. Check that the specified product key is valid and that it matches the target edition.

Does this mean that I won't be able to use the key from the DVD? Are they not the same edition? If they are, how do I go about activating the server? If the key can't be used, does this mean I will have to make a reinstall using the DVD?

Excuse me if this sounds like a question that can be answered through a simple Google search, but believe me, there is very little documentation, and that's why I'm turning to you guys.

share|improve this question
What happened when you started over and followed the directions as they were given? – Michael Hampton Jul 19 '14 at 6:43
Tried that first. Same error. @Michael – Carlo71 Jul 19 '14 at 6:55

Have you tried activating it with the slmgr command?

slmgr /ipk <key>

and then

slmgr /ato
share|improve this answer
No I haven't. I'll give it a shit after hours, since it's a production server. I'll let you know! – Carlo71 Jul 19 '14 at 22:29
Ok I tried it after hours. After the first command, I received a message saying the product key is invalid. Then after the second command, I received a message saying that the product activation was successful. But, after reboot, I still have the desktop saying I'm still in evaluation mode. Also, do I need to include the dashes in the product key, or just type all the characters together? – Carlo71 Jul 20 '14 at 6:37
Very strange. And you're sure that your key is for the right version? (Datacenter,Standard) Yes the key can/should contain the dashes: slmgr /ipk XXXX-XXXX-XXX... – Christian Jul 20 '14 at 7:47
And I found my mistake. I'm running Windows Server 2012 (non R2!), and the DVD I bought is R2... geez... Thanks anyway! – Carlo71 Jul 21 '14 at 3:01

You can't use a Server 2012 R2 product key to activate Server 2012, and vice versa.

share|improve this answer
I thought it was possible to get an R2 license with downgrade rights? – Colyn1337 Nov 18 '15 at 18:08
@Colyn1337 What are you downgrading from? Where did you hide your time machine? – Michael Hampton Nov 18 '15 at 18:13
@Colyn1337 Not sure why you posted that, since it only confirms what I said above. You may have downgrade rights, but you still have to use a different product key. – Michael Hampton Nov 18 '15 at 18:26
Does it? "Perform the downgrade process to the eligible downgrade product using the media/key from a genuine, previously licensed OEM or retail product." – Colyn1337 Nov 18 '15 at 18:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.