Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install the Media Foundation feature onto a Windows 2012 R2 box in preparation for it to be used as an RDS Session Host.

However, all attempts to install fail with:
Installation of one or more roles, role services, or features failed. The source files could not be found. Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f

Please find the dism and cbs logs -->here<--

The Windows box is fully up2date as of today with all Windows Updates. I have specified the file location as WIM:F:\sources\install.wim:4, where F:\ is the mounted Windows DVD (tried RTM + Update1 DVD's). There is a WSUS on the Network, and the Policy is set to:

Never attempt to download payload from Windows Update: Disabled

Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS): Enabled

I have installed other features successfully using this method before.

I also tried with and without specifying a source with the same result.

I did a CheckSUR to make sure that the component store is not corrupt.

The Windows Installation is one which had the local file store removed (Features on Demand) to keep the footprint small. (i.e. Get-WindowsFeature | Where-Object {$_.Installed –eq $False} | Uninstall-WindowsFeature -Remove)

Unfortunately, I don't really know what to do from the errors in the log file.

I can see instances of:

2014-07-23 16:28:22, Info CBS Failed to internally open package. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]

2014-07-23 16:28:22, Info CBS Failed to OpenPackage using worker session [HRESULT = 0x800f0805]

I can see that it downloads some packages but has some troubles there:

2014-07-23 16:27:03, Info CBS DWLD: Bundled index = 1

2014-07-23 16:27:03, Info CBS DWLD: Windows update server URL: http://download.windowsupdate.com/d/msdownload/update/software/updt/2014/05/windows8.1-kb2965500-x64_df916a7e348b2d53dbdc8e7f1828d0d1f7b5c3ca.cab

2014-07-23 16:27:03, Info CBS DWLD:Content is Full-Cab package.

2014-07-23 16:27:03, Info CBS
Failed to copy to path on bundle: 1 [HRESULT = 0x80246013 - Unknown Error]

2014-07-23 16:27:03, Info CBS WU: WSUS service is the default, URL: (null), Name: Windows Server Update Service

as well as:

2014-07-23 16:28:24, Info CBS Exec: Processing complete. Session: 30385793_3994419723, Package: Microsoft-Windows-ServerCore-Package~31bf3856ad364e35~amd64~~6.3.9600.16384 [HRESULT = 0x800f081f - CBS_E_SOURCE_MISSING]

2014-07-23 16:28:24, Error CBS Failed to perform operation. [HRESULT = 0x800f081f - CBS_E_SOURCE_MISSING]

2014-07-23 16:28:24, Info
CBS Session: 30385793_3994419723 finalized. Download error: 0x800f094b [CBS_E_SOURCE_MISSING_FROM_WUSUS_BYPASS_EXPRESS], Reboot required: no [HRESULT = 0x800f081f - CBS_E_SOURCE_MISSING]

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I was able to solve this problem by:

  • Mounting the C:\ drive of another VM which has not removed the OnDemand features
  • Pointing to that drive's Windows directory (i.e. H:\Windows in my case)

doing that, the feature installed correctly...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.