Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a hard time after having my Ubuntu upgraded. The main problem is that I have a postgis enabled database since postgresql 8.4. I have always updated the OS and databases, as soon as the news versions were released. But when I upgraded from postgresql 9.2 and postgis 1.5 to postgresql 9.3 and postgis 2.1, problems have started.

I have already tryed the hard upgrade suggested in many website, but with no success. So I decided to downgrade to the versions I had before, 9.2 and 1.5. So there were two ways of getting postgis scripts. The first (the old one) was through the contrib packages. The contrib packages of all versions of postgresql (8.4, 9.0, 9.1, 9.2) does not have scripts for postgis 1.5. At least not that I could find it. The second way (the new one) is to install the package postgresql-X.X-postgis, but this way all the packages installed are related to postgis-2.X.

Does anyone has knowledge or experience with that? Thanks a lot!

I figured it out! I installed postgresql 9.1 from ubuntu, and got the source of postgis 1.5.8. Despite of the manually procedure, it worked! :)

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.