Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Server 2012R2 VM running on a VSphere ESXi 5.0.0 (1489271) Host. It has been updated and patched to allow support for 2012R2.

Within my VM I have several disks (Thick Provisioned). However, upon deleting data on these disks, Explorer does not see the free space - in fact, after deleting about 120GB of data, one disk still has only 2GB free.

I'm stumped. Disk Management also reflects the same data as Windows Explorer with respect to the free space - is this a VMWare thing, or a Windows thing? Any ideas?

Even WinDirStat is showing incorrect stats. See images in WinDirStat and Explorer.

WinDirStat Stats of one of the problem drive

Drive in Explorer

Properties of all folders in the Drive

share|improve this question
    
Can you post a WinDirStat of the drive in question? sourceforge.net/projects/windirstat –  Spencer5051 Jul 26 at 22:23
    
Definitely not a VMware thing. Have you checked whether you have any stuck VSS (not VMware) snapshots on the drive? That might be causing the data to stay around even after you've deleted it. –  Per von Zweigbergk Jul 26 at 22:49
    
No VSS snapshots. Will try and get WinDirStat. –  PnP Jul 27 at 9:37
    
Updated with images. –  PnP Jul 27 at 10:38
    
Do you have deduplication enabled? –  MDMarra Jul 27 at 18:28

2 Answers 2

up vote 1 down vote accepted

Sounds like you're running into this: http://support.microsoft.com/kb/2897997

You need to schedule and run a garbage collection job to free up no-longer-needed blocks. If you haven't done that, do it. If you still have issues, see the support article linked above.

See this article for info on how to properly set up dedupe jobs: http://technet.microsoft.com/en-us/library/hh831434.aspx#BKMK_JOBS

It's not just next, next, next, done from the GUI.

share|improve this answer
    
MDMarra, thanks, I already tried the Garbage Collection which wasn't clawing back the space. However the above hotfix did resolve the problem. Thanks for the link. –  PnP Aug 3 at 18:32

The only solution I found to this problem was to simply robocopy the data off to another disk (NAS etc.) and reformat the drive in question - then finally copy the data back. Quite a frustration given I am dealing with 100GBs of data but such as life.

Potentially a command line that would of resolved the freespace issue

Start-DedupJob E: –Type GarbageCollection -full
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.