Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Basically, here's the gist of my issue:

I've compiled my own version of MySQL with some Sphinx magic sprinkled in it. However, because its compiled from source and not installed from any package management system, anything that requires mysql-common still wants to the package manager to install it. For dpkg the solution to this problem seems to be equiv packages. I've created an equiv package with equiv-control and equiv-build and it appears to build fine, but I can't get it to actually think I've already installed the mysql-common package. Everything that depends on that package still wants to install it from the repo.

Below I've attached the document I'm using to build the .deb with equiv-build. Can you see any problems with this? Any suggestions on possible fixes? Or even alternative solutions to my problem would be welcome.

Package: mysql-common-sphinx
Version: 1.0
Maintainer: Michael Wright <email address hidden>
# Pre-Depends: <comma-separated list of packages>
# Depends: <comma-separated list of packages>
# Recommends: <comma-separated list of packages>
# Suggests: <comma-separated list of packages>
Provides: mysql-common
Replaces: mysql-common
# Architecture: all
# Copyright: <copyright file; defaults to GPL2>
# Changelog: <changelog file; defaults to a generic changelog>
# Readme: <README.Debian file; defaults to a generic one>
# Extra-Files: <comma-separated list of additional files for the doc directory>
Description: mysql-sphinx package
  mysql-sphinx package
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Did you actually install the equivs package you built? Do this with a dpkg -i packagename.

It looks like what you showed should work. You might try naming the package mysql-common instead of mysql-common-sphinx. You might need to adjust the version number to be the same as the version number of the real mysql-common package.

share|improve this answer
    
I did install the package. I'll try renaming and updating the version to be the same as the real mysql-common package, but my worry then is having to maintain equivalent version numbers in the future. But I'd take a now fix and worry about automating this last step later. Thanksk! –  user3233 Sep 2 '09 at 17:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.