Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm seeing lots of messages in my /var/log/messages file like this:

Sep  2 17:36:47 hostname kernel: lockd: couldn't create RPC handle for 192.168.0.1

This server is NFS mounting a few directories from 192.168.0.1.

I have no idea where to start diagnosing this, and I'm pretty sure it's related to this http://serverfault.com/questions/61594/what-does-no-locks-available-mean

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I can tell you that they are directly related. Once you resolve the issue with lockd / rpc.lockd, your Subversion lock issues will go away.

Can you verify that lockd / rpc.lockd started correctly on 192.168.0.1? From your client, can you do 'rpcinfo -u 192.168.0.1 100021' ?

This thread has some useful information on lockd issues

share|improve this answer
    
# rpcinfo -u 192.168.0.1 100021 give this output: rpcinfo: RPC: Timed out program 100021 version 0 is not available That means it's not running? How do I restart it? –  Rory Sep 2 '09 at 17:07
    
Is there anything in dmesg on 192.168.0.1 re: lockd? ie, 'lockd: new process, skipping host shutdown' or 'lockd_up: makesock failed, error=' Also, can you check /proc/sys/sunrpc/rpc_lockd and see what value that is? –  Tel Janin Sep 2 '09 at 17:19
    
restarting the nfs server fixed it –  Rory Sep 3 '09 at 10:13
add comment

Chances are that your NFS server is not running the rpc daemon. Try mounting your nfs with the "-o nolock" option. If that gets rid of your error messages, you have your reason. If there is only one client mounting that NFS share at a time, it should be safe enough to use the nolock option. This emulates the older NFS method of maintaining local locks only instead of remote locks.

share|improve this answer
    
restarting the NFS server solved it –  Rory Sep 3 '09 at 10:10
    
was the rpc process killed? –  sybreon Sep 3 '09 at 11:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.