Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are having a problem deploying a reporting services report to a sql reporting services computer that is configured in SharePoint Integrated mode. I can successfully deploy to the SharePoint document libraries set up for reports and data connections if I do it locally from the box that SharePoint and Reporting Services are deployed on. If I try and do the same thing with the exact same deployment properties from a remote box, I constantly get a Reporting Services Login dialog popping up and no combination of domain\username and password will work. I've even tried the machines local admin account and still nothing.

Any ideas where to start looking?

share|improve this question
add comment

2 Answers

I had similar issue with SQL Server 2008 Reporting Services in Native mode. After going into IE settings (Tools, Internet Options, Connections, Lan Settings, removing tick 'Use a proxy server', I could now browse to the report server webpage from report server and my own computer ( http://serverIPAddress/reportserver ). When prompted to logon, I could use my logon credentials. I was now able to deploy the report from Visual Studio to report server (no longer prompted to authenticate).

share|improve this answer
add comment

I finally found the solution to this issue. Basically the build of sql server 2008 reporting services I installed added an RSWindowsNegotiate setting into rsreportserver.config file and I was running the reporting service under an account other than Network Service. I removed the RSWindowsNegotiate setting and just left the RSWindowsNTLM setting and everything started working properly for us.

More info can be found here, Solving the Reporting Services Login Issue

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.