Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi all and thanks in advance for taking the time to read this.

My employer has provided me with three VMDK files, each representing a different hard drive of a VM. My aim is to get these converted to VHD and uploaded into an Azure environment.

The issue is, after I have converted these and uploaded them into Azure, I can't get them to complete provisioning and run cleanly. As it turns out SysPrep has not been run on this OS drive, so I imagine this could be the issue here. If anyone can confirm or deny this it would be a good start!

So basically what I'm trying to do now is boot into the OS VMDK and run SysPrep on the image so I can export it and try the conversion again with the new image. However, when I try and launch the VM after configuring the settings, I get the following error on a blue screen during the boot process:

UNMOUNTABLE_BOOT_VOLUME

This goes back to the beginning of the boot process and will loop until the guest machine is stopped. I have tried booting in safe mode also and am having the same issue.

Does anyone have any suggestion as to what the root of the issue may be? I'm new to virtualization so this is the first time I have had to do something like this, and no one in the office appears to have any further knowledge than I do.

If it is of any use, the OS on the drive is a 64 bit instance of Windows Server 2008 Standard.

Thanks for any and all suggestions!

share|improve this question
    
I wouldn't think SysPrep has much to do with it; it basically gets Windows ready to regenerate setup information, most notably the GUID. From the sounds of it, I'd guess that the image doesn't have storage controller drivers for the VM. What type of storage controller have you configured for your VM? And can you at least confirm the original VMDK works, using something like VMware Player? Then do the conversion and see if you can't get it to run in a local Hyper-V instance first? –  DarkMoon Jul 29 at 20:50
    
Thanks for the comment. This error message I'm getting is actually in VMWare itself, so I am unable to boot into it at all. I have also tried Oracle's VirtualBox and am getting the exact same issue. I have installed the Hyper-V tools locally and will attempt to run the VHDs in a local instance. –  Nick Chambers Jul 30 at 8:42
    
Ok. So what storage controller type did you attach the hard drive to? LSI of some sort? Paravirtual? –  DarkMoon Jul 30 at 8:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.