Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell R300 server with two ethernet ports, running Windows Server 2008. I'd like to use one IP address, and connect to two switches. I only need one port at a time, I don't need more speed. The idea is, if one switch or one ethernet port goes bad, traffic continues on the other.

I had something like this set up with "bridging" the ports, and assigning an IP address to the bridge, but this had unintended consequences. When the network topology was reconfigured, the switches suddenly stopped switching traffic between each other. After much troubleshooting and resetting the switches to default configuration, the R300 server was tracked down as the culprit. With even only one ethernet port plugged to one switch, the switches would stop talking. Removing the bridging mode on the R300 (or unplugging it) solved the problem. So, whatever solution is provided, I'd like it to avoid this switching problem.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I believe the R300 comes with Intel interfaces right? Install the Intel Proset tool, and setup a team in the "Adapter Fault Tolerance" mode. Here is a link on how to setup AFT on Windows Server 2008 core install

share|improve this answer
    
Yep. This is the way to go. –  joeqwerty Sep 2 '09 at 19:43
    
The ethernet adapters are onboard "Broadcom NetXtreme Gigabit Ethernet". Checking the device IDs and the PCI database, it is a BCM5722 chip. Broadcom has a "Broadcom Advanced Control Suite" which sounds analagous to "Intel Proset", so I'll try that. –  axus Sep 3 '09 at 17:50
    
Yep, it already had "BACS" pre-installed, but I needed to install a newer version to actually get the failover option. Broadcom calls it "teaming", and has a few options during setup. I also found out that installing this while "bridged networking" is setup up will crash your machine right away, and on every reboot, until you disable it from safe mode and uninstall it. Anyways, problem solved! Thanks for pointing me in the right direction. –  axus Sep 4 '09 at 21:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.