Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an ASUS PIKE 2208 ( this is LSI SAS2208 ROC ) configured and working with four physical drives. Additionally I have installed the LSI SNMP agent. The agent provides all the data defined by the LSI-MegaRAID-SAS-MIB.

However, I've noticed that after LSI MegaRAID SNMP agent is started the values (on Objects such as LSI-MegaRAID-SAS-MIB::temperatureROC.0) do not change over long or short periods of time. Put simply, values seem to remain the same once the snmp agent has started. However simply restarting the snmp agent seems to (sometimes) update the values.

Interestingly, if a consistency check or patrol read are performed, values from the SNMP agent seem to update (the drive temperature fluctuates both up and down - not just up as one may expect from increased disk activity).

I'm running Centos 6.5 with the following versions of the LSI MegaRAID software:

Agent:LSI MegaRAID SNMP Agent Ver 3.18.0.2 (Oct 30th, 2012) firmwareVersion = 23.16.0-0021:3.270.95-2635:Jul 12 2013:14:20:36 driverVersion = megaraid_sas:06.505.02.00

rpm -qa | grep sas
kmod-megaraid_sas-v06.505.02.00_centos6.3-1.x86_64
sas_snmp-13.01-0300.x86_64
sas_ir_snmp-13.01-0300.x86_64

The MegaRAID MSM is MegaRAID_Storage_Manager-13.01.04-00.noarch

And MegaCli is MegaCli-8.02.16-1.i386

All of these packages are installed through the LSI provided packages. Any dependencies have been installed through yum, so they should be up to date.

I find it hard to believe that there are no temperature changes (not even \pm 1 degree) at all throughout a day (as the temperature of the environment is not nearly constant).

Everything else works properly so I find this odd. I should note that snmpwalk -v 2c -c public localhost pdTemperature gives the same temperatures as MegaCli64 -PDList -aALL | grep Temp - so where ever these utilities are obtaining their data from is consistent.

If anyone has seen this or solved this issue I would appreciate some insight as to why these values don't seem to update.

share|improve this question
    
Does snmpwalk -v 1 give the same result as -v 2c? I seems to recall some equipment might report different values between different SNMP versions. –  Abel Cheung Aug 1 at 22:51
    
-v 1 and -v 2c both give the same output. Here is a picture over a few days –  Marm0t Aug 4 at 15:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.