Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Currently I am eveluating Microsofts new WorkFolder feature which sounds very promissing to abendon the messy folder redirection feature. So I installed the feature using ServerManager under "File and iSCSI Services" and ran through the wizard.

However when I try to create the the share i receive:

Create sync share failed: The WS-Management service cannot process the request. The service cannot find the resource identified by the resource URI and selectors. 

Next I tried to accomplish the task using powershell:

PS > New-SyncShare WorkFolderTest C:\WorkFolderTest -User "MYDOMAIN\Domain Users"

This fails with the following quite puzzling error:

New-SyncShare : Not found
At line:1 char:1
+ New-SyncShare WorkFolderTest C:\WorkFolderTest -User "MYDOMAIN\Domain Users"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Msft_SyncShare:Root/Microsoft/.../Msft_SyncShare) [New-SyncShare], CimE
   xception
    + FullyQualifiedErrorId : HRESULT 0x80041002,New-SyncShare

According to some posts on technet people where able to solve this by previously sharing the folder (C:\WorkFolderTest in my case). However that didn't work for me. What am I doing wrong here? Thanks in advance.

[Addendum]

The application event log shows up the following errors. So this is somehow related to IIS WebCore.

Source:  HostableWebCore
EventID: 2276
Details: The worker process failed to initialize correctly and therefore could not be started.  The data is the error.

Source:  HostableWebCore
EventID: 2269
Details: The worker process for app pool 'SyncSharePool', PID='3916', failed to initialize the http.sys communication when asked to start processing http requests and therefore will be considered ill by W3SVC and terminated.  The data field contains the error number.

Source:  MsiInstaller
EventID: 1002
Details: Unexpected or missing value (name: 'x86\1033', value: '甅닔ă') in key 'HKLM\Software\Classes\Installer\Components\55EAFA0B8A4403B428FDE038B252C621'

Also I can't start the "Windows Sync Share" service. It fails with:

Windows could not start the Windows Sync Share on local computer. For more information, review the system event log. If this is a non-microsoft service, contact the service vendor, and refer to service-specific error code **-2147024713**.

System eventlog says:

Source:  Service Control Manager
EventID: 7024
Details: The Windows Sync Share service terminated with the following service-specific error: 
Cannot create a file when that file already exists.
share|improve this question

1 Answer 1

up vote 0 down vote accepted

I was able to solve this problem using the most important competence a windows engineer needs to have:

Reboot the system...

Although the Install-WindowsFeature Cmdlet clearly says no reboot is required... it IS required. Solved!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.