Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm on a Google Compute Engine running Debian. I'm trying to write a simple context file for jetty. My file is like:

<?xml version="1.0"  encoding="ISO-8859-1"?>
<!DOCTYPE Configure PUBLIC "-//Mort Bay Consulting//DTD Configure//EN" "http://jetty.mortbay.org/configure.dtd">
<configure class="org.mortbay.jetty.webapp.WebAppContext">
  <set name="contextPath">/some/path/somewhere</set>
  <set name="war">/var/myapp/mypath/mywar.war</set>
</configure>

My distribution came with Jetty 6. I tried it on Jetty 6; I tried it on Jetty 8, Jetty NEVER seems to read this context file. I called it myapp.xml and placed in in /etc/jetty/contexts and /etc/jetty8/contexts. Jetty 8 came without jetty-contexts.xml file, so I downloaded one from the Internet and added it.

But no matter what I do, the app is never available from the context path I specify. If I put the app in /usr/lib/webapps in a file called myapp.war then it is available from /myapp, but I need it to be a few directories deep and I can't do that with just the file name, as far as I know.

I've looked at many guides and instructions pages, but I can't figure out what I'm doing wrong.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.