Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have windows 8.1 64 bit with an on-board network card (LAN: Intel® Gigabit Ethernet Controller driver for Windows 8.1*)

Now - please notice : I have created an Acronis IMG right after installing Windows & basic programs (office,antivirus).

My computer topology :

----> router ----> computer 


Prior to logmein installation - I could awake my computer from sleep (S3 IMHO) just by trying to connect to the computer via :

myDynDnsName:3389 ( router redirect port 3389 to my pc)

(notice: I could do it from WAN / iphone / from-work)

The computer would wake up ! and then I could see the login screen.

I think it used "wake-on-link" as you can see here:

Wake on Link Settings

Wakes the computer if the network connection establishes link while the computer is in standby mode. You can enable the feature, disable it, or let the operating system use its default.

I believe that's my case.

All ok.

So where is the problem ?

After installing LogMeIn (and after resetting the computer) - the computer stopped from waking up (while sleep..) !

After uninstall LogMeIn - (and restart) - the computer still didn't awake from sleep!

Just to make sure it was LogMeIn - I restored(Acronis) my computer to the state before logMeIn installation - and the functionally was back! - I was able to wake the computer while sleep.


What should I do in order to wake my computer like I used to ? ( while keeping logMeIn).

nb today it's logmein - tomorrow it can be OtherLogMeIn...

Also - there is a checkbox in LogMeIn preferences("wakeOn**Lan**") this is checked in my computer. ( but again- there is no lan here - IMHO).

Notice : I don't have the regular powere management screen in device manager but :

enter image description here

share|improve this question
They have a history of abusing other people's address space and not removing all their software components during uninstall. Have you looked at those articles on the net describing how to uninstall the leftovers from this software? – kasperd Aug 14 '14 at 10:50
@kasperd Thank you for reply. ( and not just downvoting without leaving a comment). Are you saying there is a tool for complete removal like ESET ( for example) has ?....update didnt find officeial tool – Royi Namir Aug 14 '14 at 10:51
p.s. - I thought that there is tweak which will allow me to awake + still use logmein – Royi Namir Aug 14 '14 at 10:55
As far as I know the official uninstaller doesn't work. But somebody else figured out which drivers were left over and how to remove them. I never used the software, I have just seen articles about the problems with it. – kasperd Aug 14 '14 at 10:55

I would try 3 things:
1. After installing LMI, try to reinstall the LAN driver for win 8.1 - check if it solves the issue
2. Try to wake your computer from LMI dashboard and not by using RDP.
Maybe the LMI takes control and the only chance to wake up your computer is by using LMI dashboard?
3. contact LMI support addressing this issue.

share|improve this answer
up vote 1 down vote accepted

Ok. I found the problem.

Although I'm upset that this question dragged many downvotes - I still think that it is well defined question and valid for ServerFault.

Diagnostics :

My Intel driver screen at device manager is :

enter image description here

A regular ( and most known) APM tab for network card is :

enter image description here

I was suspicious about the third checkbox (which I couldn't access in MY APM tab) :

What if LMI changed this value to TRUE ?

So I run those powershell scripts here which set the value for the known 3 checkboxes ( although I cant access them via GUI)

# Get all physical ethernet adaptors
$nics = Get-WmiObject Win32_NetworkAdapter -filter "AdapterTypeID = '0' `
                                                    AND PhysicalAdapter = 'true' `
                                                    AND NOT Description LIKE '%Centrino%' `
                                                    AND NOT Description LIKE '%wireless%' `
                                                    AND NOT Description LIKE '%WiFi%' `
                                                    AND NOT Description LIKE '%Bluetooth%'"

foreach ($nic in $nics)

  $nicName = $nic.Name

   Write-Host "--- Enable `"Allow the computer to turn off this device to save power`" on $nicName ---"
   $nicPower = Get-WmiObject MSPower_DeviceEnable -Namespace root\wmi | where {$_.instancename -match [regex]::escape($nic.PNPDeviceID) }
   $nicPower.Enable = $True

   Write-Host "--- Enable `"Allow this device to wake the computer`" on $nicName ---"
   $nicPowerWake = Get-WmiObject MSPower_DeviceWakeEnable -Namespace root\wmi | where {$_.instancename -match [regex]::escape($nic.PNPDeviceID) }
   $nicPowerWake.Enable = $True

   Write-Host "--- Enable `"Only allow a magic packet to wake the computer`" on $nicName ---"
   $nicMagicPacket = Get-WmiObject MSNdis_DeviceWakeOnMagicPacketOnly -Namespace root\wmi | where {$_.instancename -match [regex]::escape($nic.PNPDeviceID) }
   $nicMagicPacket.EnableWakeOnMagicPacketOnly = $False

(notice the bottom line - EnableWakeOnMagicPacketOnly )

Reset the computer - DONE. working. :-)

The blame is both for LMI and Intel :

Intel : Why don't you expose those checkboxes in your new API GUI ? LMI : Why don't you revert the settings EXACTLY as they were prior to your installation ?

I hope this could help others :-)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.