Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using VMware Server 2.0.1-156745.i386 for Linux on Ubuntu 8.10.

When I run "vmware", it brings up what is supposed to be the login page in a browser, but it just loads a blank page.

This is the address:

Sometimes the login page comes back if you reload it a bunch of times, but this time it won't. Doing this also doesn't help:

/etc/init.d/vmware restart

Does anyone know why this happens, and how to fix it?

share|improve this question

10 Answers 10

up vote 2 down vote accepted

I've experienced this several times.

Different fixes fix it from time to time, and I'm still not certain of the root cause or (i suspect) causes.

sometimes fixes it:

/etc/init.d/vmware-mgmt restart

sometimes fixes it, if you're using a self-signed certificate:

  1. in Firefox, Preferences -> Advanced -> Encryption
  2. select View Certificates and find the cert for your vmware server
  3. delete the cert, then navigate to https://hostname%3A8333/ again
  4. do the standard "accept this forever" dance, and cross your fingers

I've dug into the error with Firebug once or twice, but nothing conclusive.

Sorry to be so hand-wavy, but good luck!

share|improve this answer
Didn't work at all for me... – Neil Sep 3 '09 at 19:09
yes, clearing the browser cache usually fixes it for me, but i've had to resort to the other steps on more than one occasion also. amusingly, on preview i scanned to make sure i led with that solution, and mis-read baumgart's answer as the start of my own. ;-) – jeff Sep 3 '09 at 23:28

I've seen that issue several times. I've dealt with this by clearing my browser cache, and then re-loading the page.

I have fewer issues with this on my Mac using Safari, but Windows users with IE or Firefox have the problem more regularly. I believe one coworker reported that Google Chrome worked more reliably.

It seems to me to be an issue with the browser, not the VMware service on the system. Clearing caches and using different browsers seems to work around the problem, but I haven't found a proper reason or solution for this yet.

share|improve this answer
This worked for me! – Neil Sep 3 '09 at 16:01
I'm glad it worked - I just wish there was a better answer. I've never had the time to dig in and find out what's really happening. – baumgart Sep 3 '09 at 16:18

My solution was to adjust the ammount of memory in the init.d script.


I replace -Xmx64m for -Xmx512m

share|improve this answer

You can try to ctrl+shift+R (refresh page, override cache) a couple of times in Firefox, before and after restarting the VMWare management (/etc/init.d/vmware-mgmt restart)

share|improve this answer

I was suffering exactly the same problem for a long time and neither these hints (CTRL-R or vmware-mgmt restart) worked for me. But some time ago i found a thread on the official vmware forum there people tracked down the problem to some SSL-protocol-wiredness between vmware-webui and current webbrowsers.

To cut things short, you must activate SSLv2 Mode on your webbrowser and maybe reload the webui via CTRL-R. You can get detailed instructions about this workaround on my Blog.

(its written in german but maybe the screenshots are helpful)

share|improve this answer
That would explain why it worked fine for me until FF3.6 - 3.6 is the first version that disabled SSL2 by default. – David Spillett Jul 13 '10 at 20:00

How much memory do you have? VMware server 2 is seriously slow when it's short on memory, when I first installed it I assumed it just wasnt working at all.

share|improve this answer
I don't think it has anything to do with memory. – Neil Sep 4 '09 at 17:39

Also, disable popup blocking in your browser for the VMWare management site.

share|improve this answer

Unfortunately, nothing is working. and I see in FireFox Error Console :

Error: vmtn is not defined Source File: https://theremotevmware:8333/ui/# Line: 122

share|improve this answer

Disabling the firefox plugin "VMware Remote Console" did the trick for me.

share|improve this answer

For anyone else landing here... another great resource post on the VMWare community:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.