Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to configure my SonicWALL to allow LDAP authentication for VPN users. I've done this before with another device, and I remember it being pretty simple. But I can't get it to work this time for the life of me.

When I enable "LDAP + Local Users" mode, enter the LDAP server information and AD group names, I constantly get either "LDAP authentication failed" or "Credentials not valid at LDAP server" errors. I've tried all different permutations of settings that make sense to me, with the same results. SonicWALL support is absolutely no help so far. I've followed their manual's instructions to a T, with no solution.

Has anyone here had this same situation? I feel like I'm missing a setting somewhere...

share|improve this question
add comment

1 Answer

up vote 12 down vote accepted

It may be small comfort, but it’s working for us. The server is Windows Server 2003 R2 and the SonicWALL has SonicOS Enhanced 4.2.0.1-12e.

Here are the settings:

  • Authentication method for login: LDAP + Local Users
  • LDAP Server tab:
    • Chose “Give bind distinguished name”
    • Bind distinguished name: sonicwall_ldap@OURDOMAIN.local (a user we created to allow the SonicWALL to read LDAP)
    • Use TLS (SSL) checked
      • Send LDAP ‘Start TLS’ request: checked
      • Require valid certificate from server: unchecked (we use a self-signed cert)
      • Local certificate for TLS: None
  • Did not configure RADIUS as a fallback.

Now, before your logins will work you have to go to the Directory tab and click “Auto-configure.” If auto-configure fails, make sure the SonicWALL’s LDAP username and password (e.g. sonicwall_ldap@OURDOMAIN.local) is correct.

After doing auto-configure make sure “Trees containing user groups:” includes the section of your AD tree that has the users who will be logging in. Once you do that, on the “Test” tab you should be able to test with:

  • User: username (Note:AD domain name should not be included in the username because the SonicWALL will search the user contexts that were specified on the Directory tab).
  • Password: (their password)
share|improve this answer
    
Did you give any special rights/groups to the sonicwall_ldap user? –  Kara Marfia Sep 3 '09 at 19:07
    
No. It is a regular member of Domain Users. (Yeah, I should probably remove that membership and replace it with something more restrictive, that only allows LDAP to work.) –  Nate Sep 3 '09 at 19:11
    
Well described! Great answer! –  geoffc Sep 3 '09 at 19:11
    
Hmm... when I enter the settings you've got, I still get "LDAP authentication failed" when I run a test login. Everything looks correct. When I go to the Directory tab and auto-configure, the trees all populate correctly, it's just the test that keeps failing. –  colemanm Sep 3 '09 at 20:39
2  
I figured out the problem, and consequently feel like an idiot. You know that checkbox in the main User Settings area that says "Case sensitive usernames"? Well that was checked. I unchecked and things work now. The issue is that when someone initially set up the AD, the user accounts were written in "John.Doe" format, I was testing with "john.doe". The newer accounts I created I made all lowercase, which is why they worked. Case-sensitivity never matters when using AD/Windows authentication, but it certainly does with raw LDAP. Thanks everyone. –  colemanm Sep 4 '09 at 23:02
show 8 more comments

protected by Tom O'Connor Jan 8 at 14:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.