Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm an AWS newbie. I'm trying to run the latest Hortonworks Sandbox VM image using Virtualbox on a Windows 2012 hvm AMI. I get an error message saying "VT-x is not available. (VERR_VMX_NO_VMX)"

What can I do to fix this?

Here's what I've tried: 1. I used the Intel PIU tool which identified that the Virtualisation bit is switched off. 2. I have gone to the Server Manager and confirmed that Hyper-V is off.

Is it possible to access the BIOS and change this setting?

share|improve this question

closed as off-topic by MDMarra, Katherine Villyard, mdpc, MadHatter, Ward Aug 16 at 19:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must demonstrate a minimal understanding of the problem being solved. Try including attempted solutions, why they didn't work, and the expected results. See How can I ask better questions on Server Fault? for further guidance." – MDMarra, Katherine Villyard, MadHatter, Ward
If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

Your Amazon EC2 instance is itself a virtual machine, and there is no "BIOS" in the way you mean. And Amazon doesn't support any form of accelerated nested virtualization.

This means, among other things, that you cannot use VirtualBox inside an EC2 instance to run 64-bit guests. (You could in theory run 32-bit guests unaccelerated, but it would be painfully slow and expensive.)

You haven't explained what you're trying to accomplish, but whatever it is, using VirtualBox inside an Amazon instance isn't going to be the way to achieve it.

share|improve this answer
    
I've updated my question. I'm trying to run Hortonworks sandbox –  user1801060 Aug 13 at 22:51
    
In that case, you're just wasting time and money trying to install the "Sandbox" on a virtual machine in an EC2 virtual machine. If you intend to run Hortonworks on EC2, then just install it normally. The Sandbox is meant for your local workstation. –  Michael Hampton Aug 14 at 13:49

Looking at the Hortonworks Sandbox installation requirements, this runs inside a virtual machine - you can choose the virtual machine to run it on from VMWare, Hyper-V and VirtualBox. Which means the answer from Michael Hampton is correct - this isn't going to work on your Amazon instance. The good news is that from the looks of it you can run this from most current Mac and Windows desktops with at least 4GB of RAM.

Good Luck!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.