Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One one of our file servers I keep getting delay write failures to the OS disk array. Its built on a Raid1 array using an on-board raid card.

So far I've verified both harddisks are ok by pulling from the machine and doing full disk checks. (Obviously not at the same time) The write failures still happen with only one disk present and will not complete a check disk when in the server.

How do I go about checking that it definitely is the raid card or is what is done enough to safely say it is the card? Bare in mind that a faulty card means a motherboard swap.

Thanks

share|improve this question
    
What's the OS? (Presumably Windows something) What's the hardware? Any other odd details about this particular machine? Usually a Windows 'Delayed Write Failure' isn't a disk problem in my experience. –  MikeyB Sep 6 '09 at 21:31
    
Windows Server 2003. Machine had been running fine for over a year before the issues started occurring so it isn't any of the usual cable/disk settings issues. –  Ryaner Sep 6 '09 at 21:55
1  
Sounds like you've eliminated the usual suspects. At this point I'd feel comfortable replacing the motherboard. As a checklist, you've covered: cables, disks, drivers & firmware, right? –  MikeyB Sep 7 '09 at 22:40

3 Answers 3

The only thing you haven't done, as far as I can tell, is to swap in fresh disks on the suspected-bad card. Don't try this with data you care about, but cloning the real data to a couple of spare disks (on another machine, followed by a check to catch a bad spare) is probably reasonable. (You do have spare disks around, right?)

The hypothesis here is that a recurrence of the problem demonstrates it is not the disks at fault.

share|improve this answer
    
I've sent the machine back to company who built it. They have swapped out the raid card for another brand, replaced the motherboard and ram, and now swapped out all the disks for different ones. Delayed writes have stopped since disk buffering is off however the writing to the array from the os disks or the other way around stops and freezes regularly. Waiting on a replacement CPU as that is all that is left! –  Ryaner Nov 13 '09 at 19:39
    
ouch! maybe the machine is just haunted?!? well, my answer was more suited to the original posting; sorry it's too late to be useful. hope you get it worked out somehow! –  quack quixote Nov 14 '09 at 2:43

First you should update drivers and firmware of the controller and read the known issues / release notes. Depending on your os and systems there are different things you can do.

share|improve this answer
    
Drivers are all up to date. System is identical to a few other boxes we are running so I need some sort of independent test before I start to disassemble it to replace the board. –  Ryaner Sep 4 '09 at 8:14

Verify that the disks you are using are supported with the server in question.

Sometimes using third party disks will cause odd issues due to slightly different behaviour or the drives not supporting ioctls that the RAID card needs.

share|improve this answer
    
Disks are supported. Using identical setup with identical disks in multiple other machines without issue. –  Ryaner Sep 6 '09 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.