Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get SNMPD working on my Zenoss server that runs Ubuntu Server 14.04. I installed it and configured it but when I start it up, i get the following error in syslog:

Aug 14 08:19:16 zenoss snmpd[9904]: Turning on AgentX master support.
Aug 14 08:19:16 zenoss snmpd[9904]: Turning on AgentX master support.
Aug 14 08:19:16 zenoss snmpd[9904]: Error opening specified endpoint "udp:"
Aug 14 08:19:16 zenoss snmpd[9904]: Server Exiting with code 1

If I run SNMPD at a command line (sudo /usr/sbin/snmpd -f) it works fine. I did a netstat -oan | grep 161 and there is nothing else binding to port 161. Here is my config file (comments removed):

agentAddress  udp:
view   systemonly  included   .
view   systemonly  included   .
rocommunity public  localhost
rwcommunity private localhost
rouser   authOnlyUser
sysLocation    Virtual Machine
sysContact     IT Manager
sysServices    72
load   12 10 5
trap2sink    localhost public
master          agentx

And my snmpd settings file (comments removed):

export MIBS=
SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -g snmp -I -smux -p /var/run/ -c /etc/snmp/snmpd.conf'
TRAPDOPTS='-Lsd -p /var/run/'
share|improve this question

The problem seems to be here:

-c /etc/snmp/snmpd.conf

Remove that from your /etc/default/snmpd so it looks like this:

SNMPDOPTS='-Lsd -Lf /dev/null -u snmp -g snmp -I -smux,mteTrigger,mteTriggerConf -p /var/run/'

If you want to get snmpd to listen on (or all interfaces) then edit:


So it looks like this:

#  Listen for connections from the local system only
#agentAddress  udp:
#  Listen for connections on all interfaces (both IPv4 *and* IPv6)
agentAddress udp:161,udp6:[::1]:161

Restart SNMP.

share|improve this answer
Thanks, but I will have to take your word that this is the solution as we don't even have Zenoss anymore. But hopefully this will be useful to someone else. – Caynadian Apr 7 '15 at 1:57

This might be a Permission problem.

under normal situations non-root users are not able to bind to ports <1024 in linux.

However if the SNMPD drops it privileges after creating the socket/endpoint then this should not be your issue.

share|improve this answer
I'm fairly new to Linux. How do I check / correct this? – Caynadian Aug 14 '14 at 13:42
try to use a different free port (above 1024) in the config file ( agentAddress), if that is working you know that it is a permission problem and can narrow it down with the search engine of your choice. – Dennis Nolte Aug 14 '14 at 13:57
No, that didn't work either: Error opening specified endpoint "udp:". – Caynadian Aug 14 '14 at 14:00
Well, I tried using the servers IP address instead (ie: udp: and that didn't work. I then tried just commenting out the line entirely and that DID work. It binds to This will work for me although I didn't really want to allow outside access. – Caynadian Aug 14 '14 at 14:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.