Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting desperate for answers.

The problem is simple, some email messages are getting stuck in our queue and hitting their retry limits, which ultimately end up in a never end deliverable bounce back.

When I try to go in the queue manually send them the following happens:

LOG: MAIN cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1XGwKf-0005ag-Fg delivering 1XGwKf-0005ag-Fg Connecting to cogentpowerinc.com.inbound10.mxlogicmx.net [208.65.144.2]:25 ... failed: Connection refused LOG: MAIN
cogentpowerinc.com.inbound10.mxlogicmx.net [208.65.144.2] Connection refused Connecting to cogentpowerinc.com.inbound10.mxlogicmx.net [208.65.145.2]:25 ... failed: Connection refused LOG: MAIN
cogentpowerinc.com.inbound10.mxlogicmx.net [208.65.145.2] Connection refused Connecting to cogentpowerinc.com.inbound10.mxlogic.net [208.65.144.3]:25 ... failed: Connection refused LOG: MAIN
cogentpowerinc.com.inbound10.mxlogic.net [208.65.144.3] Connection refused Connecting to cogentpowerinc.com.inbound10.mxlogic.net [208.65.145.3]:25 ... failed: Connection refused LOG: MAIN
cogentpowerinc.com.inbound10.mxlogic.net [208.65.145.3] Connection refused LOG: MAIN == brian.paterson@cogentpowerinc.com R=lookuphost T=remote_smtp defer (111): Connection refused

Everything I tried:

  1. Made sure PTR / rDNS was properly set up.
  2. Made sure each domain on my server had SPF record set up.
  3. Made sure each name never and domain on my server was correct.
  4. Contact mxlogic (MacAfee) they said emails were never reaching their system.
  5. Flushed out IP tables.
  6. I contacted my host made sure port 25 was open.
  7. Repaired permissions on inboxs.

I currently have our system administrator looking into it, but I am at a lost, everything I read and tried to do has failed to work.

Does anyone have any ideas?

share|improve this question
    
That host responds normally for me. Are you firewalled? What and where is your server? –  Michael Hampton Aug 15 at 18:37
    
Can you telnet to port 25 from a shell? Port 25 is old-school. > telnet mail.server.com 25 Connected to mail.server.com (x.x.x.x). Escape character is '^]'. –  Satalink Aug 15 at 18:39
    
1  
1  
My System Admin is looking at it right now, if I find an answer I will share in detail. –  Dan Aug 15 at 19:24

1 Answer 1

This may point you in the right direction

SMTP Tweak

You may want to prevent users from bypassing your mail server to send mail. This is common practice for spammers. This feature allows you to configure your server so that the mail transport agent (MTA), Mailman mailing list software, and root user are the only accounts able to connect to remote SMTP servers.

Source: http://docs.cpanel.net/twiki/bin/view/AllDocumentation/WHMDocs/TweakMail

If your clients are not setup to handle sending mail as an authenticated user, suddenly enabling SMTP Tweak in WHM will cause…

mailin-01.mx.aol.com [205.188.146.193] Connection refused
cluster9.us.messagelabs.com [216.82.242.19] Connection refused
cluster9a.us.messagelabs.com [95.131.108.66] Connection refused
xxx@xxx.com.au <xxx@xxx.com.au> R=lookuphost T=remote_smtp defer (111): Connection refused
mailipao.vtcif.telstra.com.au [202.12.144.27] Connection refused
xxx@telstra.com <xxx@telstra.com> R=lookuphost T=remote_smtp defer (111): Connection refused
gmail-smtp-in.l.google.com [209.85.221.11] Connection refused
alt1.gmail-smtp-in.l.google.com [216.239.59.27] Connection refused
alt2.gmail-smtp-in.l.google.com [74.125.79.114] Connection refused
alt3.gmail-smtp-in.l.google.com [72.14.221.27] Connection refused
alt4.gmail-smtp-in.l.google.com [209.85.216.62] Connection refused

Uhoh. cPanel’s SMTP Tweak does this by adding these rules to iptables:

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     tcp  –  anywhere             localhost           tcp dpt:smtp
**REJECT     tcp  –  anywhere             anywhere            tcp dpt:smtp reject-with icmp-port-unreachable**

Source: https://sysadminspot.com/server-administration/emails-not-sending-defer-111-connection-refused-exim-and-smtp-tweak/

share|improve this answer
    
The SMTP restriction is disabled. –  Dan Aug 15 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.