Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up a DFS to centralise my shares. After doing so, I noticed, that I can access the shares via the domain path (\\SNAKEOIL.LOCAL\Research), but the folders is shown as empty.

The intended namespace \\SNAKEOIL.LOCAL\Public is working as expected.

Why is that and how can I avoid this strange behaviour?

Servers are running Windows Server 2012 R2. Howevery, I have the same problem with 2008 R2, too. Here is my setup:

SOIL-DC1 (domain controller, DFS)

  • D:\Shares\Research (shared as \\SOIL-DC1\Research)
  • D:\Shares\Laboratory (shared as \\SOIL-DC1\Laboratory)

SOIL-DC2 (domain controller, DFS)

  • D:\Shares\Development (shared as \\SOIL-DC2\Development)

\\SNAKEOIL.LOCAL\Public (DFS-Namespace)

  • Research (targets to \\SOIL-DC1\Research)
  • Laboratory (targets to \\SOIL-DC1\Laboratory)
  • Development (targets to \\SOIL-DC1\Development)
share|improve this question
    
Do you have permissions for all these folders? Windows will hide folders you don't have access to. –  Nathan C Aug 18 at 12:10
    
Will hide only with ABE enabled. But this is not the issue here. –  Daniel Aug 18 at 19:16

1 Answer 1

up vote 0 down vote accepted

This happens, when the DFS server is also a domain controller.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.