Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Struggling to get MSMQ installed in Domain Integration mode on Windows 2012 (Azure). So far, I've provisioned a brand new Windows Server 2012 (R2) machine on the Azure platform and installed the Active Directory role and promoted the machine to a domain controller.

Once the AD was in place, I then added the MSMQ feature, along with the Directory Integration add on.

However, it will not install in AD integration mode. It will only work in Workgroup mode.

I can verify this by running the following powershell command:

New-MSMQQueue -name Queue1 -queuetype Public

When I run this command, I get the following error:

New-MsmqQueue : A workgroup installation computer does not support the operation.

The event viewer reveals to errors in the Application log:

1. The Message Queuing service failed to join the computer's domain 'DOMAIN'. Error 0xc00e0025: 

2. Message Queuing was unable to create the msmq (MSMQ Configuration) object in Active Directory Domain Services. Error c00e0025h: 

I'm struggling here. Any advice?

share|improve this question
    
Would appreciate feedback on why the question was downvoted. –  SimonGoldstone Aug 19 at 20:43

1 Answer 1

Can we get some more information on this? Below are some questions that came up for me after reading our post.

Did you replace 'DOMAIN' to omit your domain name or did you really try and create a domain named DOMAIN? That seems like a generic message and might not be the issue.

Have you confirmed that your Active Directory is actually working? Can you join other computers to the domain? Have you tried running DCDiag and Netdiag to validate the configuration?

There are also some specific things you have to do to get MSMQ working in this mode on an actual domain controller. Here is an example for 2008 on what needs to be done.

Any chance this helps?

share|improve this answer
    
Thanks for your reply. Yes I changed the domain to protect identity. The actual domain is valid. Yes AD is working, other machines are able to join. Thanks for the link, I'll check that out and report back... well done. –  SimonGoldstone Aug 20 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.