Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to troubleshoot a DNS issue I am currently having with a new project host on an AWS EC2 instance. It is a brand new domain, and I have already updated the nameservers on the registrar side.

It's been a couple days so the new records have propagated. Upon digging, I have verified the NS records are being correctly pointed to:

; <<>> DiG 9.9.5-3-Ubuntu <<>> creativealchemyhealing.com in NS
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32418
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;creativealchemyhealing.com.    IN  NS

;; ANSWER SECTION:
creativealchemyhealing.com. 172800 IN   NS  ns-1467.awsdns-55.org.
creativealchemyhealing.com. 172800 IN   NS  ns-364.awsdns-45.com.
creativealchemyhealing.com. 172800 IN   NS  ns-640.awsdns-16.net.
creativealchemyhealing.com. 172800 IN   NS  ns-1551.awsdns-01.co.uk.

NS Records Good. So next i went to verify the A record that I set up in the AWS Hosted Zone is querying correctly to the elastic IP of my EC2 instance:

;; QUESTION SECTION:
;creativealchemyhealing.com.    IN  A

;; ANSWER SECTION:
creativealchemyhealing.com. 300 IN  A   54.183.25.131

A Record looks propagated. Excellent.

So then I checked the IP itself to see if that loaded... IP address loads fine: 54.183.25.131.

So why then does the actual domain not query properly? www.creativealchemyhealing.com

What am I missing? Is there a more effective solution to troubleshoot DNS issues other than using the dig utility?

share|improve this question
    
Can you include dig output for the name you say that you have problems with (www.creativealchemyhealing.com)? The +trace +add options may be helpful in case something is actually wrong with the delegation. –  Håkan Lindqvist Aug 21 at 6:58
    
+1 for this question from me, for not redacting the domain name. Made solving the problem easy, instead of a punishing series of how-about questions. Thanks, Robert. –  MadHatter Aug 21 at 7:04
    
@HåkanLindqvist I'm interested in learning more about how to better troubleshoot an issue like this in the future, so I was playing with the dig options you suggested, but I am unable to identify the syntax for using them. After looking through the help manual on dig it appeared I should use the following syntax: dig www.creativealchemyhealing.com in NS +trace, however its producing no output. Nor is +add option, and I can't even find that one in the man page. I've tried about 20 other syntax forms and none of them produce output either. Can you suggest the syntax you would use? –  McWayWeb Aug 21 at 7:27
    
in linux I can write dig www.creativealchemyhealing.com +trace +add (ubuntu), what platform are you on? –  Sverre Aug 21 at 7:39
    
@Sverre Ubuntu as well. I tried that one actually: ; <<>> DiG 9.9.5-3-Ubuntu <<>> www.creativealchemyhealing.com +trace +add ;; global options: +cmd ;; Received 28 bytes from 127.0.1.1#53(127.0.1.1) in 2 ms –  McWayWeb Aug 21 at 7:46

1 Answer 1

up vote 2 down vote accepted

www.creativealchemyhealing.com is not the same as creativealchemyhealing.com

you need another A record for that one, or a cname

for example

www.creativealchemyhealing.com. 300 IN  A   54.183.25.131
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.