Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using openSUSE 13.1.

I created a new directory on a zpool

zfs create zpgd0/iSCSI -o compression=lz4 -o atime=off

but I'm not looking on that... So I do it again but I'm getting...

zfs create zpgd0/iSCSI -o compression=lz4 -o atime=off
cannot create 'zpgd0/iSCSI': dataset already exists

adding some data

zpool history 
History for 'zpgd0':
2014-08-11.13:38:21 zpool create -f zpgd0 raidz2 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0490461 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0603473 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0606817 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0670246 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0673599 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0715212 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0722699 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0731193 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0732862 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0806663 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0807385 scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0816943
2014-08-11.14:13:09 zpool set autoexpand=on zpgd0
2014-08-11.14:14:32 zfs create zpgd0/espacio
2014-08-19.11:47:47 zfs create zpgd0/iSCSI -o compression=lz4 -o atime=off

 zpool status -v
  pool: zpgd0
 state: ONLINE
  scan: none requested
config:

    NAME                                            STATE     READ WRITE CKSUM
    zpgd0                                           ONLINE       0     0     0
      raidz2-0                                      ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0490461  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0603473  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0606817  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0670246  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0673599  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0715212  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0722699  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0731193  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0732862  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0806663  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0807385  ONLINE       0     0     0
        scsi-SATA_WDC_WD4001FAEX-0_WD-WMC1F0816943  ONLINE       0     0     0

errors: No known data errors

I have no errors but the folder does not appear, so what Can I do?

sorry add it

zfs list
NAME          USED  AVAIL  REFER  MOUNTPOINT
zpgd0         933K  35,5T  54,7K  /zpgd0
zpgd0/iSCSI  54,7K  35,5T  54,7K  /zpgd0/iSCSI
share|improve this question
1  
What is the output of zfs list? –  ewwhite Aug 21 at 20:20
    
sorry added that... –  maniat1k Aug 21 at 20:40

1 Answer 1

up vote 2 down vote accepted

Your new filesystem is in /zpgd0/iSCSI. To access it, you can cd /zpgd0/iSCSI.

If it is not currently mounted, you can use zfs mount zpgd0/iSCSI.


Due to the naming of the filesystem, I'm betting that you probably want to create a ZFS zvol to present as block storage for iSCSI. If that's the case, what you're doing is taking you down the wrong path.

share|improve this answer
    
ok did not worked with cd... I'm very new to this wit zfs mount worked out. thanks! –  maniat1k Aug 21 at 20:44
    
You said that I was taking down the wronkg path... why do you say so? –  maniat1k Aug 21 at 20:48
1  
@maniat1k because you have to supply the -V <size> parameter to your zfs create call to set up volumes. Also, you probably also want -s for sparse allocation. What you have done is creating another data set to host files, it would not work as a block device equivalent. –  the-wabbit Aug 21 at 23:26
    
Ahh, now I see what you mean. We are not going to expose the raw space to iSCSI but several files which are the speciffic iSCSI fileio devices. –  maniat1k Aug 22 at 13:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.