Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am facing a weird situation in my network environment.

My infrastructure looks like this:

I have a D-LINK DIR-635 acting as my default gateway (192.168.0.1)
A physical Windows 2012 Server (192.168.0.10) with the following roles: DHCP, DNS, AD DS and Hyper-V.
A virtual Windows 2012 Server (192.168.0.50) which I intent to use as an IIS server (Role is not deployed yet).

My virtual machine was able to get an IP address from the DHCP server and is working perfectly (I can ping the default gateway [by IP, FQDN or DNS Alias], the Hyper-V host and any site on the Internet (CNN.com for example).

However I cannot ping the VM from my host. It says: Request Timed Out.

Do you guys know what I might be doing wrong?

Any support is appreciated!

Thanks!

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Sounds like you're using a private virtual switch as your hyper-v switch for that guest. You can review the different types of switches in hyper-v and their effects here.

If this isn't the case, try running a tracert and adding the results here so we can have a better idea of what's going on.

For this particular instance however the issue was caused by the ICMPv4-In rule being disabled. In other words the guest OS firewall was the cause.

share|improve this answer
2  
Hi Reaces. I just read that my guest firewall could be the cause. I enabled the File and Printer Sharing (Echo Request - ICMPv4-In) rule and everything is working fine. Thanks for your support! –  Kaguei Nakueka Aug 22 '14 at 9:04
    
"Virtualquebec" .. clearly trying to take credit! lol. What I do is write those rules in to Group policy so I don't have to worry about them when adding/rebuilding servers. –  Aceth Aug 24 '14 at 21:38
    
Not sure why this is marked as an answer to the question when it's not, while the problem may have been solved the answer should be improved with information for whatever the solution was. –  Shaun Wilson Aug 10 at 1:18
    
@ShaunWilson I hadn't really looked at this answer / question again. You can always suggest an edit putting into the suggestion that the information you added was gotten from a comment that indicated it to be the answer. Or create a seperate answer to the question including the new information. Commenting to people to change their answers might not be the easiest way to go about it. –  Reaces Aug 11 at 9:33

Looks like your firewall IS active on the VM or a dns problem, try to Ping the IP adress of your vm, if It work, this mean you did not set the same dans on your server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.