Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm mounting a samba share with some sparse files over cifs with -o username=user,gid=999,uid=999,rw,vers=1.0. The NAS has 3TB capacity and 500 GB free disk space, creating a 4TB sparse file with truncate -s 4T file.img is no problem. When I mount the share with vers=2.1 I get the error file too large for truncate invokations size size > 2GB as well as for dd, e.g. dd if=/dev/sda12 of=/mnt/samba_share/output.img results in

dd writing to '/mnt/samba_share/output.img': File too large`
4194304+0 records in
4194303+1 records out
2147483647 bytes (2,1 GB) copied, 33,5466 s, 64,0 MB/s

There's obviously no problem for the underlying filesystem to create the sparse file (it's not recognized in cifs 1.0, but that's another issue, I guess). Why does samba or DSM limit the size? How to overcome this?

Samba protocol version 2.1 seems to be the latest supported (there's a checkbox for SMB2 support in DSM 5 control panel; specifying vers=3.0 as mount option causes errormount error(22): Invalid argument`).

share|improve this question
    
Are you using a 32-bit or a 64-bit server? You do not mention the OS, distribution, version either. –  mdpc Aug 24 at 2:05
    
The processor architecture is armadaxp, I'd say that the architecture is 32-bit [marvell.com/embedded-processors/armada-xp/assets/…, but Synology seems to do a lot to hide useful information. All the rest is stated clearly in the question - DSM is short for Synology Diskstation manager! –  Karl Richter Aug 24 at 9:21
    
Realize that a 2GB individual file size is characteristic of 32-bit situation. –  mdpc Aug 24 at 16:35
    
Ok, I get it, I really don't seem to be able to figure it out and asked serverfault.com/questions/623797/… –  Karl Richter Aug 25 at 12:22
    
I'm having the same issue with CentOS 7 (64-bit) and the latest cifs-utils pkg, along with an Isilon cluster running OneFS 7, and a Windows 2008 R2 Server with a direct attached RAID connected to it, shared out via SMB. If I force vers=2.1 in fstab or mount.cifs, then I can't copy files over 4GB in size. Isilon and 2008 R2 both support SMB 2.1. If I force vers=1.0 in fstab or mount.cifs I do not have this problem! But the speeds are crap -- I'm using 10Gb, and cifs 1.0 is limited in read and write sizes. Any ideas, anyone? Please do not say use NFS -- that is not an option. We use AD to hand –  NiqueK Aug 28 at 1:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.