Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an Ubuntu 8.04 web server on which I had an exim4 installation. I had e-mail set up with a smarthost, but I changed it to local mail only using

dpkg-reconfigure exim4-config

The problem is now that e-mail is not delivered locally. No e-mail is delivered at all, actually.

Is there a way to completely reset the configuration of exim4, so that it works like in a new installation?

share|improve this question

1 Answer 1

dpkg-reconfigure exim4-config again, and choose the correct options this time :-).

Exim4-config pops up with the dialog you get for dpkg-reconfigure when installed, so there's no real config that's 'like in a new installation'. Ever new installation is different.

share|improve this answer
    
Thanks for your reply, but I already tried that with different settings. It always worked fine on a test server, but not on the production server. There was a problem with the host name. I changed it in /etc/hostname, but hadn't executed sudo /etc/init.d/hostname.sh start yet. Now everything works fine. –  pvoosten Sep 7 '09 at 7:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.