Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got the following setup:

  • Windows 2008 R2 server: Remote Desktop Services (RemoteApp, Session Host, Services Manager)
  • Windows 2008 R2 server: AD + AD Certificate services + DNS
  • Windows 7 client PC, in the domain, logged on as local admin (which is also a domain admin)

Whenever I try to launch RemoteApps from the client PC, I get a password popup. The password authenticates fine, and the app starts, but launching another one will show another password popup. Why doesn't it automatically authenticate, seeing as I'm in the domain?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You can absololutely use SSO, but it requires some fiddling. I don't know if you're using a connection broker or a gateway in your environment, but from your description it sounds like you're running tests in a small lab. So, in order for Web SSO to work, you have to digitally sign every remoteapp "program" you publish, and the client must trust the certificate you are using to sign the programs. This blog entry paints the big picture, hope it's enough for you to get going:

http://blogs.msdn.com/rds/archive/2009/08/11/introducing-web-single-sign-on-for-remoteapp-and-desktop-connections.aspx

share|improve this answer

SSO is not working out of the box in AD. If you want true SSO you need to implement some kind of ticket system like Kerberos. If you just want it for terminal server you can delegate your credentials (this can be set through GPO and is described here)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.