Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 2008 server with two NICs running RRAS and a small public website. It also does NAT for several other PCs on my network and everything works great. I have a block of 5 public static IPs from my ISP, one of which is bound to the public NIC in the Windows 2008 server. I would like to assign one of the remainging 4 public IPs to a machine on my private network. I thought I could do this by going into RRAS, selecting NAT under IPv4 and then adding the public IP address to the address pool and specifying a reservation for the machine I would like to use that address by adding its private ip address.

When I do this, the machine I reserved the public IP address for seems to loose all outside network connectivity. I can still ping other PCs on my 192.168.0.* net, but anything outside is no longer reachable. When I remove the reservation, everything seems to work. After setting the reservation and right clicking on the external public interface and selecting 'Show Mappings' I can see outbound requests from my private address with the desired associated private address, however I do not see any inbound requests.

What am I doing wrong/missing?

share|improve this question

I know this is an old post and it surely got solved by now but I had a similar problem and I solved it in a very simple manner. Maybe this will help someone.

At me was even worse than this: I had 2 internal network clients loose conectivity to the internet(not only the computer with the reserved address) and it even disrupted the smtp communication for all clients.

You simply need to add the ip addresses assigned to you by your isp to the ip addresses on the interface connected to the internet: at the internet connected network adapter - tcp/ipv4 -advanced - ip settings - ip addresses - add .

That way the routes will be updated automatically and everything will work as it should.

Here is on the third step - first point:

share|improve this answer

It seems you did everything correctly... have a look here, maybe it can help.

share|improve this answer
Thanks for the confirmation on what I thought was correct. Something has got to be whack tho, as the setup does not work. Any thoughts on how I can trouble shoot/diagose the problem? – Art Sep 6 '09 at 23:04
up vote 0 down vote accepted

Here is what I did to fix it, although I am not quite sure why this resolved the problem. Can someone who is more versed in networking elaborate? I came to this through playing around and expirimentation.

In RRAS I added a static route with the Destination IP address set to the reserved public IP address I added to the Address pool. I set the network mask to, the gateway to and the Metric to 276.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.