Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Windows Vista Business and installed IIS 7 (I changed no settings in it, everything is on default). I have a domain and have setup Dynamic DNS for it with the host. I use a program provided by the host to update my server's IP. I have a Netgear router which I've configured the HTTP port (80) to forward to my server.

The problem is when I try to access the default website by typing in the domain's URL, all I get is a "Waiting for http://www.mydomain.com" message which eventually just returns:

This webpage is not available.

The webpage at http://www.mydomain.com/ might be temporarily down or it may have moved permanently to a new web address.

More information on this error Below is the original error message

Error 101 (net::ERR_CONNECTION_RESET): Unknown error.

Here's what I tried:

  1. I disabled the firewall on my server completely to see if it would resolve the issue, but no joy.
  2. I've pinged the www.mydomain.com and it replies perfectly.
  3. I've tried to flush the DNS (ipconfig /flushdns) via command prompt.
  4. Accessing http://localhost on the server and http://myservername from other network computers works just fine.

I don't know what I'm missing, anyone have any ideas?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

When you pinged www.mydomain.com did the reply come from the correct ip address, the one that's registered with the Dynamic DNS service?

Have you turned off the external web management feature of the Netgear router? Netgear routers allow web based (port 80) management connections from both the internal and external interfaces by default. This might be causing the problem as your attempt to browse the server might actually be going to the router instead, since ip address on the WAN interface on the router is the same ip address that's going to be registered with the Dynamic DNS service and ultimately NAT'ed through the router to the server for http traffic.

share|improve this answer
    
Yes to both. That's all in order. –  Mr. Smith Sep 7 '09 at 3:31
    
When it fails, is it failing from a host on the same LAN? Have you tried from a host on another network? –  joeqwerty Sep 7 '09 at 3:34
    
Yes it's failing on the same LAN. I haven't tried to access it from a different network, I'll do that in about an hour when I get to work and post the results. I also put IIS7 on another network computer and changed the port forwarding, same result though. –  Mr. Smith Sep 7 '09 at 3:39
    
Maybe it has something to do with the way the traffic is being routed through the router. The request originates from the same LAN as the server, but has to access it via the public ip address. I have an IIS7 box and a Linksys router and have no problems accessing my web sites via their public ip addresses frm the Same LAN as the server. From an internal host try to tracert to the public ip address of the server and see what the results are. –  joeqwerty Sep 7 '09 at 4:03
    
Hey Joe, I tried accessing the site from a different network and it it's working just fine! Is there anyway to resolve the problem of not being able to view the sites on my local network via it's public domain? –  Mr. Smith Sep 7 '09 at 4:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.