Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I configure a VM instance to be accessible via IP address anywhere, right now the IP address of the VM is only accessible on my local server machine via the local IP assigned by VMware. E.g.: I want to access the VM from any machine on my local network http://VMINSTANCEIPADDRESS%3A80

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Go to VMware Workstation and select the virtual machine you wish to make changes to.

With the virtual machine selected go to > Edit virtual machine settings (a new window will open)

On this window select Network Adapter > under Network Connection select > Bridged.

What Bridged does is connect the vm directly to the network

share|improve this answer
1  
What is the "Replicate physical network connection state" check box? –  Daniel Sep 7 '09 at 19:19
1  
Replicate the physical network connection state for mobile users — If you use virtual machines on a laptop or other mobile device, enable this new link state propagation feature if you use bridged network connections (not NAT). As you move from one wired or wireless network to another, the IP address is automatically renewed. –  Luis Ventura Sep 7 '09 at 23:20
    
@LuisVentura: I'm trying to configure exactly as you suggested but after switching from the default NAT to bridged mode, the internet stops working in VM instances –  user01 Feb 21 '12 at 9:53

If you set the networking connector to use the "bridged" setting and then restart the networking in the host (rebooting should do this), then the IP assigned to the VM will come from your router (assuming it is using DHCP), not from within VMWare, and the address should be routable from anywhere in the local network. If you are using static IP, set the VMWare network connector to bridged and assign the VM a static IP as you would normally (varies by OS), reboot and proceed as above.

share|improve this answer
    
After switching from the default NAT to bridged mode, the internet stops working in VM instances –  user01 Feb 21 '12 at 9:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.