Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a web part in MOSS showing a table of contents for a site. I just have a big problem because one of the subsites of this site is missing from the table of contents. How do I get it back?

It's in the right posistion if I inspect the treeview of the site structure. like most of the other subsites its icon is 4 colored figures.

If I look at navigation for the root site the subsite in question is missing and I can't figure out why or how to get it back...

I tried to add is as a link or a title but that doesn't fix the problem with the table of contents not showing this site - help will be greatly appriciated!

share|improve this question

Most likely that site is hidden. In the site directly above the missing site, go to Site Settings -> Navigation

In the little tree view that appears, find your site. It should say "Hidden" next to it. Click your site, then click the "Show" button at the top of the tree view. Click OK and your site should reappear in navigation.

share|improve this answer
It's not hidden unfortunately - I checked before. The list of sites that should include "Web Editors" (the missing site) does not include that site. I can add the site to navigation by adding a link or a heading but that does not make the site appear in the table of contents... – noesgard Sep 10 '09 at 11:18

Or, check if the site in question has it navigation settings set to "show current only" and has the checkbox "use same navigation as parent" (not surte of the exact names here) unchecked. You can check these settings under the site actions menu using the Change Navigation menu option,

share|improve this answer
The navigation settings for the "Web Editors" site (the missing one) is (sorry about the naming, I'm translating from another language): Show sub web sites, sort manual, show navigation under current site, use navigation fra this site – noesgard Sep 10 '09 at 11:21
up vote 0 down vote accepted

I found out that the problem was caused by the default limit of the query web part (TOC), which defaults to 50 elements.

Problem solved by setting a proper value for the limit according to this:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.