Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a (very) old server with 3 x 9gb SCSI drives in a raid 5 configuration.

After some power issues the server came back up with a degraded logical drive according to the cards bios. The card sees the card, reports the logical drive is degraded and then continues on with its post. However, after the card bios screen has dissapeared, the server wont continue to boot (black screen with flashing cursor). Unable to boot from other media too.

Ultimately, we plugged the pci card into another machine (xp pc) leaving the drives to be powered by the original server (due to the drives being inside one of those huge cages, i wasnt going to fanny about trying to take it out). The PC sees the card, reports the drive the same as the other, boots into windows, but will not see the drive. In Disk Management it asks to initialize the drive and then convert it to a dynamic disk. Seeing it as an unformatted 18gb drive.

I tried booting from an ubuntu cd but although it reports the scsi card as being there, it will now show up what /dev/sd* the drive is and will not allow me to mount it.

Any ideas?

So far its looking as if the drive is borked :(.

The annoying thing is the fact that we only need 1 file off the drive!

Thanks in advance. Rob

share|improve this question
    
What happens if you pull the failed disk out? And try and boot to just the two that aren't failed? –  Laura Thomas Sep 8 '09 at 18:21
    
Sorry for my late reply on this. I took the failed disk out. Still no joy but it does act a bit differently. If the drive is unplugged, the system will request boot media. If the drive is present, it attempts to boot from the degraded logical drive and sticks at the flashing cursor. –  Rob Sep 10 '09 at 8:59

1 Answer 1

This does not help you, but:

"RAID is not a backup solution" is what we are all thinking!

Do you have a backup of the RAID card configuration? It sounds as if that's been reset...

share|improve this answer
    
I know. And believe me, my servers are all backed up (and I used 10 as opposed to 5, but that isnt here nor there :) ). This server belongs to a 3rd party, and although id love to just turn around and say "i told you so!, we suggested to replace that server years ago", I told them to bring it in and we would take a look and try and be helpful. In answer to your question re card config: no. –  Rob Sep 8 '09 at 15:09
    
A bit of progress on this, the netraid configuration tools shows the drive as failed and a rebuiled fails with an error at 31%. –  Rob Sep 8 '09 at 16:08
    
Ok, I think we can put this one to bed. Ran gparted from a livecd and it finds the 16.x gb logical drive. But with an unknown filesystem. So I think i can safely say it's borked. –  Rob Sep 10 '09 at 9:25
    
Sorry about that. –  Guy Sep 11 '09 at 11:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.