Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This question has been sitting unanswered on superuser.com for a while now without answer. Thinking about it, I'm wondering if it might be better asked here. What I'm looking for is how to diagnose this problem - not alternatives like VNC etc...

Original post on superuser.com here: here:http://superuser.com/questions/33289/how-to-diagnose-remote-assistance-problem

Full transcript of original question below.


I have a long standing issue with remote assistance between a home and work PC. My wife and I both use MSN messenger and I used to be able to control her PC at home via MSN Remote Assistance. Some time ago however this stopped working and I don't know why.

We're both running the latest versions of MSN Live Messenger and I've checked the appropriate firewall ports are open, but it still doesn't work and MSN just says something useless like "The person isn't responding".

Any suggestions for how can I diagnose this?


More info: I just tried direct Remote Desktop between work PC and home PC and it works fine - so I presume all the appropriate ports are open. Just Remote Assistance doesn't work.

I'd like to get RA working so I can demonstrate how to do things remotely. With Remote Desktop the person at the other end gets booted off and can't see. With Remote Assistance they can follow along step by step.

Some comments below suggest using other solutions, which is fine and do work, but there must be a way to diagnose RA and get it working.


The person you are trying to help isn't responding


Experimenting with this some more, the notebook that I was using at work today that refused to connect works fine for remote assistance when I bring it home. So I guess this must be a problem with our network configuration at work. I've checked that 3389 is open on firewall on office router and remote desktop works both ways.... just not remote assistance.

I've read that remote assitance won't work if client and server are both behind Non-UPnP/NAT routers. If one has UPnP it's supposed to work. Office router doesn't have UPnP enabled but my home one does.

I've also scoured the event logs on both ends, nothing noteworthy - unless I'm looking in the wrong spot).

share|improve this question
    
You already have your answer. It's a firewall/routing issue at your work. –  Izzy Sep 9 '09 at 3:58

2 Answers 2

Just configure port forwarding for the port 3389 on your non-UPnP router.

share|improve this answer

Just a thought, did you enable Remote Assistance? Probably a stupid question.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.