Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have IIS running on a windows 7 ultimate machine (development workstation). I can access the website locally with no issues, but when I try to access the site from the iPhone it just gives one of two errors:

Cannot Open Page
Safari cannot open the page because the server stopped responding

or

Cannot Open Page
Safari cannot open the page because the server cannot be found

Can't quite figure out what triggers one message vs the other, but both machines (computer and iphone) are on the same wireless network and have the same subnet mask. On the laptop, the network connection is defined as a "home network" and I've turned on all the sharing options I could find.

What other troubleshooting steps can I try?

additional info:

  • just wanted to include that I know that iphones don't support netbios so as such wouldn't be able to resolve the machine name. I am trying to access the machine by IP ...
  • I installed a ping app on the iphone and I'm able to ping the workstation with 0% packet loss

solution was enabling the built-in firewall rule for http traffice on home/work networks :-)

share|improve this question

4 Answers 4

up vote 3 down vote accepted

IIS or netbios can't be the issue. Your iphone is just unable to connect. Check your IIS port, make sure that your comp. firewall allows access, and don't forget to type that at the end of ip when trying to access from iphone. e.g. 1.1.1.1:8080 of course you dont' need to do that if it's port 80. good luck

share|improve this answer

You have to find out the ip of your personal web server (iis). Normally it is in DHCP mode. Type that ip (i.e. 192.168.2.30).

share|improve this answer

Is the iPhone on a wireless LAN with the workstation or is it running over the public 3g network? If it is the former, check the firewall. If it is the latter, you probably need to talk with network support about getting some firewall holes punched.

share|improve this answer
    
it was definitely on the LAN :-) this was in my home and I wouldn't want outside traffic coming into my laptop's IIS server :-P –  Joel Martinez Oct 9 '09 at 17:51

Have you checked the firewall settings?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.