Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I try to turn off "discard" on an ext4 file system but I cannot succeed.
I tried to add "nodiscard" option in /etc/fstab but I can still see this

# tune2fs -l /dev/md2|grep disca Default mount options: journal_data_writeback user_xattr acl discard

share|improve this question
2  
Why do you think modifying the fstab would change the default mount options that stored in the filesystem metadata? Changing the fstab options will only change the options used at mount time. –  Zoredache Oct 20 '14 at 21:06
    
Well, because I couldn't find any better ideas to try. I looked on the internet on ways to set the fs to "nodiscard" but I couldn't find anything. –  Alex Flo Oct 21 '14 at 6:10

1 Answer 1

up vote 2 down vote accepted

the command to remove "discard" is this
tune2fs -o^discard /dev/md2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.