Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've stumbled upon a strange behaviour with Windows machines, which seems to be fairly consistent between all Windows versions from Vista/2008 to 8.1/2012 R2; it doesn't happen instead when using Windows XP or Windows Server 2003.

The problem is this: when the network adapter is configured for DHCP and the DHCP server doesn't register DNS records on behalf of its clients (because it can't, or because it's not configured to do so), then the forward A record gets registered, but the reverse PTR record doesn't.

Some more details:

  • Both the forward and the reverse DNS zones are AD-integrated and accept dynamic updates.
  • All computers are joined to the domain.
  • All computers use the correct internal DNS servers, both when configured statically and when getting their configuration from DHCP.
  • "Register this connection's addresses in DNS" is enabled in the network adapters.
  • Everything is fine when a computer has a static IP address; both the forward and the reverse records get automatically registered.
  • When the same computer is configured for DHCP, the forward record is registered, but the reverse record isn't.
  • This happens for all computers with an OS version >= 6.0, and it's definitely not related to a single machine.
  • No amount of ipconfig /registerdns will change anything.
  • No errors are logged anywhere.

Why does this happen, and how can it be fixed?

And no, configuring the DHCP server to perform DNS registration is not an option here.

share|improve this question
    
A friend not on SF said: "That's normal, PTR is only updated by DHCP in Win2K+". That doesn't exactly seem to be the case from your experience, but might be close.... I'm trying to dig up a better reference. –  Chris S Oct 24 at 14:07
    
Massimo, are you able to pull a wireshark trace and check the DHCPREQUEST Packet? There should be a flag set to "1" if the client is supposed to update both the A record and PTR record. A flag of "0" means the client updates the A record and requests that the server update the PTR record on its behalf. Default is "0". –  TheCleaner Oct 24 at 14:21
    
Also in the DHCP scope make sure == Click the DNS tab, click Properties, and then click to select the Dynamically update DNS A and PTR records only if requested by the DHCP clients check box == is set. This would mean when the default flag of "0" comes in the server will then try to register the PTR record with the DNS server(s) it is configured to update. And make sure the DNS dynamic update credentials are correct and appropriate permissions are applied for this to work –  TheCleaner Oct 24 at 14:28
    
As I said in the question, configuring the DHCP server is not an option. I don't manage it. It won't register DNS records for its clients, period. They should be able to handle it, since all of them are domain members. –  Massimo Oct 24 at 15:03
    
I have the same issue. Using pfSense as DHCP server. Win2k8 DC/DNS. Win7 clients. The clients are registering A records, but not PTR records. –  Corey Oct 29 at 18:53

2 Answers 2

According to MS:

Windows 2000 .. sends option 81 and its fully qualified domain name to the DHCP server and requests the DHCP server to register a pointer resource record (PTR RR) on its behalf. The dynamic update client registers an address resource record (A RR). .. the DHCP server can be configured to instruct the client to allow the server to register both records with the DNS.

Statically configured (non-DHCP) clients register both the A RR and the PTR RR with the DNS server themselves.

The article also mentions Changing registry entries changes the behavior of the dynamic update DNS client. So there might be a registry workaround... Looking


Edit:
According to the article linked by TheCleaner below, the GPO I mentioned in my comment will not do what you want (yeah MS and closed-source software). But checking the boxes for "Register this connection's address in DNS" and "Use this connection's DNS suffix in DNS registration" makes it work. I don't have a convenient test environment to try it...

share|improve this answer
    
I don't have a setup convenient to test, could you try enabling the GPO Computer Config > Templates > Network > DNS Client > Register PTR records and see if that has the desired effect - I'm thinking it might not, but worth a shot. –  Chris S Oct 24 at 14:24
1  
    
The GPO doesn't change anything, but enabling "Use this connection's DNS suffix in DNS registration" actually did the trick. Please rewrite your answer to explicitly state this, and I'll accept it. –  Massimo Oct 24 at 15:47
up vote 2 down vote accepted

The solution is checking Use this connection's DNS suffix in DNS registration in the TCP/IP settings of the network interface:

enter image description here

As much as it may appear strange, this is the only solution to ensure Windows will register both the A and the PTR records for a DHCP network connection; otherwise, it will only register the A record.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.