Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem that I've been inspecting for a while now, googling and everything but could not begin to understand. I'm really not used to java, even less tomcat. So there it is.

First, the setup.

  • Centos 5.3 on a virtualized server.
  • Bitnami Native Alfresco stack (tomcat5.5, mysql5, java, javajdk, JDBC)

Content of catalina.log. Since it's the shortest and where I found my first clue to what is going wrong: SEVERE: Error listenerStart

Aug 27, 2009 5:32:58 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Aug 27, 2009 5:32:58 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 229 ms
Aug 27, 2009 5:32:58 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Aug 27, 2009 5:32:58 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.25
Aug 27, 2009 5:32:58 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Aug 27, 2009 5:34:47 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Aug 27, 2009 5:34:47 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/alfresco] startup failed due to previous errors
Aug 27, 2009 5:34:48 PM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Aug 27, 2009 5:34:48 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Aug 27, 2009 5:34:48 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/11  config=null
Aug 27, 2009 5:34:48 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Aug 27, 2009 5:34:48 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 110327 ms
Aug 27, 2009 5:38:27 PM org.apache.coyote.http11.Http11BaseProtocol pause
INFO: Pausing Coyote HTTP/1.1 on http-8080
Aug 27, 2009 5:38:28 PM org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
Aug 27, 2009 5:38:29 PM org.apache.coyote.http11.Http11BaseProtocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080

There's the content of catalina.out, it seems to be a stack trace or application trace of the error, is that right?

Catalina.out gist on github

There is a 404 error telling me this: The requested resource (/alfresco/) is not available.

This is it. I think.

share|improve this question
    
Have a look at localhost.yyyy.mm.dd.log and post if there is anything interesting. –  Stu Thompson Sep 13 '09 at 17:36
    
Nothing of interest. Same stuff. –  Infernalsirius Sep 17 '09 at 1:26

2 Answers 2

This line in your error log would suggest the problem lies with your database configuration:

org.springframework.beans.factory.BeanCreationException: 
  Error creating bean with name 'luceneIndexBackupComponent' 
  defined in class path resource [alfresco/core-services-context.xml]: 
  Invocation of init method failed; nested exception is 
  org.springframework.transaction.CannotCreateTransactionException: 
  Could not open Hibernate Session for transaction; 
  nested exception is org.hibernate.exception.GenericJDBCException

Check your Hibernate configuration as something is not right.

My guess would be you have configured Alfresco to use an external database (e.g. MySQL), but you haven't installed the appropriate driver (e.g. Connector/J for MySQL). See this Alfresco forum post for more information:

http://forums.alfresco.com/en/viewtopic.php?f=8&t=14483

share|improve this answer

It looks like the alfresco/file-servers.properties file contains some errors.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.