Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I set up a dual boot for win 7 from vhd on 2 xp machines. One of them everything went fine, and I get the option to choose the os when I turn the machine on. The other was slightly different in that rather than seeing the current OS disk (the one with XP on) as the c:\ when I was setting up windows 7 vhd during install it saw the disk as d:. I didn't think anything of it and went ahead and created a vhd on the d: drive.

Now when I turn this machine on, it boots straight to win7 and I never get the option to choose xp. When I look at the boot option in msconfig, I only see Windows 7.

How can I go about adding the old XP drive as a boot option at startup again?

Edit: Strangely when I rebooted this time (perhaps the first time since I removed the install DVD) it boots to XP. I suppose I'll just have to reinstall windows 7 again in a new vhd...

share|improve this question

You can try editing your boot.ini file in the root of your system drive. Mine looks something like this, but I only boot to one OS, you'll likely have to add a line under [Operating Systems] that looks very similar to what I have.

[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

share|improve this answer
but under windows 7 it doesn't use the boot.ini file anymore. It uses the new boot manager that started with vista. My boot.ini still has my one entry for XP, and now since the reboot it seems to be using it. – Sam Holder Sep 11 '09 at 15:09
Try this site: – IceMage Sep 11 '09 at 15:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.