Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I understand that you could just fix the certificate issue or you could go to each pc and do the following:

Internet Options, Advanced, uncheck "Warn about certificate address mismatch".

But is there a way to set this in the GPO so that it does it for everyone?

share|improve this question
1  
Doesn't that defeat the object of having security warnings? I'd make this a training issue, personally. –  user3914 Sep 11 '09 at 14:14
2  
Wouldn't it be easier to just fix the certificate? –  Justin Scott Sep 11 '09 at 14:16

1 Answer 1

up vote 4 down vote accepted

This is the registry key you need to tweak:

HKEY_USERS\"USER  SID VALUE"\Software\Microsoft\Windows\CurrentVersion\Internet Settings\WarnonBadCertRecving

And Microsoft has a great article about making registry changes across your enterprise HERE

Now, I do have to say that this strikes me as a poor idea. This removes pretty much all the fraud protection built into SSL-but after weighing the options, the tools are there to make the change.

share|improve this answer
    
+1 pointing out the bad-idea-ness and still answering the question. –  squillman Sep 11 '09 at 15:07
    
+1 - The idea of disabling this security warning is a BAD idea! –  Dscoduc Sep 11 '09 at 16:42
    
an Enterprise-wide registry hack is not the way we want to go obviously. I'm going to look into the reasons for the certificate error and I'll post a follow up. –  jasoncrider Sep 13 '09 at 22:26
    
I followed up and found out that the problem revolves around intranet pc's hitting one IP and outside users hitting another. They decided to route the internal to a non-secure site to get around it. –  jasoncrider Sep 14 '09 at 18:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.