Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have several domain controllers running, one name resolves to the internal IP, where the name resolves to an external IP on the other domain controllers. I don't see any entry for the name I am querying, and I don't see the zone. What might be going on?

Update:
I will call the domain I am having trouble with foo.bar.com , and my companies domain baz.com.

Under forward lookup zones, there is no folder for bar.com. When I run dig @mydc01 foo.bar.com I get the internal IP:

;; ANSWER SECTION:
foo.bar.com.    0	IN	A	10.1.1.1

When I run the same command against my other DNS servers ( ie @mydc02 ), I get the public IP and the respose with the public name servers being authorative. I have tried clearing cache, and there is no host entry. I see foo.bar.com as a cached lookup, under the root folder, com folder, bar folder. In that folder, there is Name: ( Same as parent folder), Type: Name Server, Data: Our public dns servers.

More Update:
When I add +trace to dig while still having @problemServer I get the correct IP as the response.

share|improve this question
    
So when I query the other ones with dig foo.name.com @DC1 , I get the external. But when I do @DC2 I get the internal IP. –  Kyle Brandt Sep 11 '09 at 15:39
    
Are you wanting it to be resolving to the external or internal? What's the "correct" one? –  TheCleaner Sep 11 '09 at 15:45
    
TheCleaner: External. –  Kyle Brandt Sep 11 '09 at 15:53
    
Have you tried flushing the cache? –  John Gardeniers Sep 11 '09 at 16:11
add comment

4 Answers 4

Could it be the host file on that server?

share|improve this answer
    
Nope, already Checked that. –  Kyle Brandt Sep 11 '09 at 15:40
1  
Probably obvious, but there aren't host files on the other servers right? –  NickatUship Sep 14 '09 at 15:00
    
Nickat, nope. If even there were, I don't think it would matter with dig if I am selecting the server. –  Kyle Brandt Sep 15 '09 at 13:25
add comment

I assume your DC's are MS-DNS servers as well? If so, do they have the same forwarders?

share|improve this answer
    
Exactly, they are DNS servers. In this case, no forwarders. –  Kyle Brandt Sep 14 '09 at 12:32
    
Sorry if silly question; are both DC's getting regular updates for that zone ... check the serial #'s? –  James Risto Sep 14 '09 at 18:09
    
echobeach2, not silly, how do I check that the zone updates? And what do you mean by the serial numbers? –  Kyle Brandt Sep 16 '09 at 12:17
    
By "zone updates", I assuming you have a zone transfer of that zone that perhaps is out of date. However, even if you don't have a ZT of it ... DNS admin tool, or "nslookup -type=soa foo.bar.com" on command line which should output "serial =". Interestingly, this exact command works ... someone must have that domain! –  James Risto Sep 16 '09 at 14:32
add comment

I would verify that your "problem" server is pointing to the same DNS server as the other DC's. If it is pointing to itself then make sure that the DNS cache is flushed (as John said)...ipconfig /flushdns, then try the resolution again.

Also, try using dig with the full output and see if you can determine where in DNS the invalid record is located.

Make sure you are really resolving this via DNS as well. Are you querying by FQDN or just NETBIOS name? Sometimes WINS (if around) can cause discrepancies for short name resolution.

share|improve this answer
add comment

Check the order of your registered DNS servers against the order in the other servers that work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.