Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The Magnetic Stripe Reader that I'm using and testing is just supposed to be sending keystrokes. Unfortunately, it seems to randomly be sending upper case and lower case keystrokes, sometimes substituting % for 5 and ^ for 6 and vice versa. (If you've ever programmed for a magnetic strip reader, you know that's not a good thing.)

Is there something in the RDP protocol that causes this? I've got kind of a convoluted system, running XP inside virtualbox on Fedora 11 RDP'ed into a win2k3 server. It works on the XP VM and it doesn't work on the RDP'ed one.

What's weirder, is that I'm not even emulating the USB drivers for my Mag Card Reader. Linux is sending keystrokes straight in to windows, and MSTSC on windows XP is sending crap to the Win2k3 server. I'm 99% certain this isn't a problem with the card reader, it has nothing to do with my programming either. (I get the same junk coming into notepad that I get coming into our software [that's why I didn't ask on SO]).

And, it works with rdesktop programs other than MSTSC.exe!

Needless to say, I'm in need of some RDP Guruship.

share|improve this question
So you're saying that in Linux, or the XP VM on the Linux machine, no matter how you swipe you never get gibberish? Just plain text? Is the card reader presenting itself to the system as a keyboard or something else? What if you RDP to another Windows computer and just try it in Notepad? If you RDP straight from the Linux machine to the terminal server using CoRD can you replicate the problem? – Josh Budde Sep 11 '09 at 17:52
@Josh: Not exactly gibberish just about 5% of text is transposed for it's up-shifted or down-shifted versions; It's all plain text with CRLF at the end; I'm not sure how the card reader presents itself, windows seriously doesn't even know it exists (but that's irrelevant I think); Any computer I RDP into does the same thing (win2k3 and win2k8 and XRPD'd into a Fedora 9 server); Don't have CoRD, but rdesktop through linux works A-Ok, so do other RDP clients in windows. – Peter Turner Sep 11 '09 at 18:17

1 Answer 1

up vote 2 down vote accepted

Well that was weird, I finally found the Local Resources Keyboard Options

  • Click Options
  • Click 'Local Resources'
  • On the Keyboard Box change 'Apply windows key combinations' to 'On the local computer'

Now you can't ctrl-alt-delete, but it seems to make the capitalization/shifting consistent. Still is a bug somewhere since it's so random when you try doing key combo's remotely (probably hits the keys too fast)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.