Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up IIS 7 on my computer and have a demo site which works fine when I go to http://localhost/ or http://<my-ip>/. However users on the intranet (my network) cannot access my site. (when they type in http://<my-internal-ip>/) Should they be able to? If not, how can I make this possible.

Thanks for any help/explanations, Andrew

share|improve this question

migrated from stackoverflow.com Sep 11 '09 at 20:38

This question came from our site for professional and enthusiast programmers.

    
It depends on how you have set up IIS. Is port 80 open on your machine? When you access it from another machine is the URL used pointing at your machine? –  Colin Mackay Sep 11 '09 at 20:37
    
@Andrew: you can accept Chris' answer, you just weren't logged in when you came back. If you log in to ServerFault (with the same OpenID that you use at StackOverflow) you should be able to come back and accept the answer. –  squillman Sep 11 '09 at 21:51

2 Answers 2

You first might want to ping your machine from another on the same network and see if it can even be seen. Secondly you might want to try the machine name instead of localhost.

http://machineName/website/index.html should work or you can try the IP address http://192.10.10.1/website/index.html and see if you can access the website that way.

Firewall configurations might also be limiting other machines from seeing your webserver. Take a look at those and see what ports are closed.

Hope this works for you.

share|improve this answer

Do a netstat -an and check where the web-server is listening (it may be only bound to 127.0.0.1), you want it to be listening on 0.0.0.0 for all interfaces.

Then check if you can ping the machine from another machine on the local network, if not, and you are happy you have physical connectivity, ie., you can ping other machines (not one of your machines IP addresses) on your local network as you describe it, then you have a firewall miss-config.

Simplest thing to do here to check, is simply to turn off he windows fireall (only if you are on a trusted private network). If the problem goes away, checkout the firewall rules and make sure you are allowing http (tcp/80) and https (tcp/443) through it to the IIS process.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.