Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to use autofs to mount an export on my Fedora 11 workstation (xulu) from a laptop running Ubuntu 9 -

but showmount runs into an annoying error -

sbeam@clammy$ sudo showmount -e xulu
rpc mount export: RPC: Program/version mismatch; low version = 3, high version = 3

but I can actually mount the NFS dir just fine with normal 'mount' command.

On the server, /etc/sysconfig/nfs contains the default, but enabling NFS V2 only results in the mismatch changing from 3/3 to 3/2

MOUNTD_NFS_V1="no"
MOUNTD_NFS_V2="no"
MOUNTD_NFS_V3="yes"

so any ideas how to resolve this "mismatch"?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I'd try commenting out all the mountd lines in /etc/sysconfig/nfs and restarting NFS on your Fedora machine.

Apparently showmount has issues if only specific versions of the mount protocol are enabled.

To force a specific NFS version, I'd use -o vers=X on the client rather than messing with the server.

share|improve this answer
    
that did it, thanks for sharing. cheers ~~ –  sbeam Sep 21 '09 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.