Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Rails app, running with nginx and Passenger. Until yesterday, logging worked, but now nginx's error.log shows this message on startup: Rails Error: Unable to access log file. Please ensure that /var/www/app/htdocs/log/production.log exists and is chmod 0666. The log level has been raised to WARN and the output directed to STDERR until the problem is fixed.

The log file has 0666 permissions. It looked like it may have been related to Issue 332, so I upgraded from Passenger 2.2.4 to 2.2.5. This didn't solve the issue. Logging worked yesterday, and nothing was changed in the configuration since then.

Any ideas?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Please check the directory privs as well:

ls -larth /var/www/app/htdocs/
share|improve this answer
    
Was missing x on the directory itself. Thanks. –  Christopher Foy Sep 14 '09 at 12:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.