Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been fighting this for hours, and I'm about ready to give up. I was in the process of getting Azure tools setup on my Win7 x64 laptop (Dell D830). The Visual Studio tools for Azure require that ASP.NET is installed. It's not enabled by default in Win7, so I attempted to install/enable it by going to Control Panel -> Programs -> Turn Windows Features On/Off

I've tried this about five times now, and I get the same error every time:

"An error has occurred. Not all of the features were successfully changed."

Every time this happens it wants to reboot, which I do.

What I've Tried:

  • The first attempt was through the Platform installer, which failed.
  • Uninstalled and reinstalled IIS.
  • Added and removed WAS (it had never been installed when I started this process)
  • Attempted to add IIS7 from command line (this resulted in an error telling me to reboot so the install could roll back)
  • Prayed real hard

More Info:

Other Windows features install/uninstall just fine. I've installed/uninstalled IIS and WAS. Only ASP.NET will not install.

This line was repeated seven times at the end of CBS.log:

2009-09-12 23:39:25, Info CBS Failed to find localized custom property bag [HRESULT = 0x80070490 - ERROR_NOT_FOUND]

I'm really stuck here, any help would be greatly appreciated.

UPDATE: I gave up and repaved the laptop from scratch. This time I didn't install any Beta stuff, especially VS 2010. All seems well now.

share|improve this question
+1 for prayed real hard – Denis Wessels Mar 13 '13 at 9:41

Well, got ASP.NET installed by "Upgrading" from the original ISO... Two hours of that and then ran the Azure tools again and this time it starts & fails. I think it may have to do with VS 2010 Beta 1 being on the same box, even though it's supposed to work. I'll be trying again with a new Win7 VHD. Wish me luck...

share|improve this answer

protected by splattne Jul 17 '12 at 12:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.